3

I downloaded the cleanthesis template and run LaTeX on thesis-example.tex which created an .aux file. In the document one finds

\nocite{*}
\printbibliography[nottype=online]
\printbibliography[heading=subbibliography,title={Webseiten},type=online,prefixnumbers={@}]

such that BibTeX should generate a .bbl file. But if I run bibtex, it just says

This is BibTeX, Version 0.99d (TeX Live 2012)
The top-level auxiliary file: thesis-example.aux
I found no \citation commands---while reading file thesis-example.aux
I found no \bibdata command---while reading file thesis-example.aux
I found no \bibstyle command---while reading file thesis-example.aux
(There were 3 error messages)

and just leaves an empty .bbl file for me. I checked cleanthesis.sty and found

\bibliography{bib-refs}

which is infact the correct .bib file.

I then deleded the command \nocite{*} and put some where in the text \cite{WEB:GNU:GPL:2010} after compiling with LaTeX I could find in the .aux file the command

\abx@aux@cite{WEB:GNU:GPL:2010}

but if I run bibtex I get the same message from above and an empty bbl file.

Am I doing anything wrong?

2
  • 1
    It's using biblatex so I think current versions will default to biber rather than bibtex, although you can probably use a backend=bibtex key to force it to use bibtex compatible aux file. – David Carlisle May 12 '13 at 16:22
  • 1
    see this line (commented out) in github version \RequirePackage[ % use biblatex for bibliography % backend=biber, % - use biber backend (bibtex replacement) – David Carlisle May 12 '13 at 16:23
4

If you do not want to run biber write before you load the package cleanthesis:

 \usepackage[                   % use biblatex for bibliography
    backend=bibtex8,                    %   - use bibtex8 backend 
    bibencoding=utf8,               %   - use auto file encode
    style=alphabetic,               %   - use alphabetic (or numeric) bib style
    natbib=true,                    %   - allow natbib commands
    hyperref=true,                  %   - activate hyperref support
    backref=true,                   %   - activate backrefs
    isbn=false,                     %   - don't show isbn tags
    url=false,                      %   - don't show url tags
    doi=false,                      %   - don't show doi tags
    urldate=long,                   %   - display type for dates
    maxnames=3,%
    minnames=1,%
    maxbibnames=5,%
    minbibnames=3,%
    maxcitenames=2,%
    mincitenames=1%
]{biblatex}

However, at least use bibtex8 if you have the encoding utf8

7
  • Thank you! I enabled backend=bibtex. If I use now pdflatex thesis-example.tex and then bibtex8 thesis-example.aux my .bbl file is still empty. Bibtex8 tells me again that he found no \citation,\bibdata nor \bibstyle. – Adam May 12 '13 at 16:35
  • I tested it with the thesis-example and bibtex and had no problem. – user2478 May 12 '13 at 16:38
  • Did you mean in your post I should change the backend=bibtex line on line 285 in cleanthesis? This is what I did, but I just saw that you said "write before you load the package cleanthesis..". I cant put in before I load cleanthesis, because I cant load the package twice. – Adam May 12 '13 at 17:08
  • @Adam bibtex and bibtex8 are two separate programs, if you want to use the latter with biblatex, specify backend=bibtex8. – Torbjørn T. May 12 '13 at 18:57
  • @Adam: either my solution or the one from torbjorn-t – user2478 May 12 '13 at 20:23
5

You should run biber, not bibtex, as the package uses the biblatex package to handle references. Newer versions of biblatex assume biber as the default backend (i.e., the program that does the sorting of the entries), so it won't work with bibtex.

To force biblatex to use bibtex or bibtex8 instead, you can edit cleanthesis.sty. Line 285 of the current version reads

%   backend=biber,  [...]

Change this to

backend=bibtex,

or

backend=bibtex8,

For some info about bibtex vs. biber see bibtex vs. biber and biblatex vs. natbib

2
  • the package sets no backend (in my version), but with current biblatex the default is biber – user2478 May 12 '13 at 16:25
  • @Herbert Yes, you are correct. I'll rephrase my answer. – Torbjørn T. May 12 '13 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.