2

I get "Missing $ Inserted" when typing in this:

Genom att undersöka var kurvan ${f_{A}(x)}$ skär linjen T = 20 ser vi att x ≈ 4,3 då ${f_{A}(x)}$ = 20.\\

Where is my fault?

3
  • 3
    Is that a unicode approx between x and 4,3? Try substituting for $x\approx 4,3$ and see if it helps. May 12, 2013 at 19:38
  • 6
    There is no missing $ here. However you should be typing kurvan $f_{A}(x)$ skär linjen $T=20$ ser vi att $x\approx 4{,}3$ då $f_{A}(x) = 20$. (And no \\, to end a paragraph use a blank line.)
    – egreg
    May 12, 2013 at 19:39
  • @egreg well there is due to the strange inputenc design (sorry for that) that some characters end up automatically being math chars so the \approx as a unicode char triggers mathmode (most likely) ... but of course you are right that it should have been written with several formulas in the first place May 13, 2013 at 20:06

1 Answer 1

4

The missing $ is probably caused by . While it may be convenient to use direct Unicode input, not all symbols are defined, so you may incur in problems.

For instance, there's no definition for with the utf8 option for inputenc, while there is (as a math symbol) with the utf8x option (that I don't recommend).

Type your text as

Genom att undersöka var kurvan $f_{A}(x)$ skär linjen $T = 20$
ser vi att $x \approx 4{,}3$ då $f_{A}(x) = 20$.

Note that T=20 is a math formula and that commas used for separating the decimal part must be enclosed in braces (or a package such as icomma should be used).

Don't use \\ to end paragraphs, just leave a blank line in the input.

Not the answer you're looking for? Browse other questions tagged .