15

I am using the following line in my document:

\usepackage[citestyle=apa,maxcitenames=2,bibstyle=authoryear,doi=true,url=true]{biblatex}

However, biblatex ignores maxcitenames, and prints out every name, every time.

Is there are way to make biblatex stop ignoring maxcitenames?

  • 1
    maxcitenames only affects the citations in the doc. body, if you want to affect the bibliography use maxbibnames instead. Or just use maxnames=2 and it will set both options to 2. – ach May 15 '13 at 16:24
  • 1
    I know that. However, I found that if I set citestyle=apa, then maxcitenames does nothing. My solution was to use citestyle=authoryear. – daviewales May 15 '13 at 22:51
  • 1
    Related: tex.stackexchange.com/questions/69028/… – lockstep May 16 '13 at 8:23
  • 1
    It doesn't mention the problem with apa styles, however. – daviewales May 16 '13 at 9:30
12

The default in biblatex is to use the uniquelist option. APA style also uses this. This option dynamically changes the maxnames/minnames settings in order to make citations unique. This is required by APA. APA style also applies APA rules regarding citation list truncation after the first cite within a paragraph. You are probably noticing the effects of these settings. APA style with maxnames=2 is essentially not APA style – these settings are partly hard-coded into the style as a result ...

  • The sad thing is that I didn't actually want APA style, I wanted Harvard style, and I was following instructions from somewhere which said you could use APA and modify it to get Harvard. As you can see, I found it easier to modify the authoryear style. – daviewales May 16 '13 at 6:56
  • 4
    Yes, it's always better to modify the default styles. Specialist styles like APA have some very tricky requirements which have to be coded into the style and are therefore not easy or impossible to change with standards biblatex package options. In fact I have added some such options to the package for some simple cases but after all, it's an APA style so adding options to make it non-APA compliant becomes suspect after a while ... – PLK May 16 '13 at 9:13
2

The solution I found was to replace citestyle=apa with citestyle=authoryear. This fixes the problem.

0

For me the only working solution, after citestyle=authoryear and style=authoryear did not work, was, to remove that parameter completely.

So, now my biblatex call is just:

\usepackage[minnames=5, maxnames=10, backend=biber,sorting=ydnt]{biblatex}

and it works correctly for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.