1

This is a recent development, and I'm not sure what I've changed to make this happen… other than setting TM_SUPPORT_PATH to ~/Library/Application Support/TextMate/Managed/Bundles/Bundle Support.tmbundle/Support/shared.

I had to do that a month ago to get LaTeX files to compile (another mystery, since it previously compiled without issue). They seem to work fine now, but when I try to create italics (or bold, underline, etc.), TextMate spits back the error:

Failure running “Italic”.

Italic: line 4: toggle_style.rb: command not found

This same error occurs when I try to invoke other scripts contained in the LaTeX bundle (Tidy, anything invoking texMate.py). All of these seem to rely on TM_SUPPORT_PATH in the script, and yet none of these scripts resides within the shared directory… They're all in ~/Library/Application Support/TextMate/Managed/Bundles/LaTeX.tmbundle/Support/bin.

I could solve this problem by changing the path in all of the scripts to a TM_LATEX_SUPPORT path, or by moving or linking all of the scripts to the shared directory… but this doesn't seem like it should be necessary. Any ideas on what I may have broken?

1

I submitted this to the TextMate mailing list, and was informed that my issue was with TextMate, not any of the LaTeX stuff on my system. The solution was to disable the custom TM_SUPPORT_PATH, then reinstall the "Bundle Support" package for TextMate.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.