3

I need to generate the List of Acronyms for a report class document, i used this method to make the acronym:

insert -> nomenclature entry

then I write the symbol and the description. Example:

Symbol: API
Description: Application Programming Interface

But when I did this:

insert -> List / TOC -> Nomenclature

in the place where I want the list of acronyms to appear nothing happens.

What am I doing wrong here, and how to insert an abbreviation table into my document?

Update:

I know about this Question but what I want is not an abbreviation table after each chapter; I want one in the beginning of the document after the table of contents.

  • I am not sure but try this: add "\addcontentsline{toc}{section}{Nomenclature}" at the position where you want to have your nomenclatur and afterwards the the list of all your acronyms. This should insert all acronyms at this position... – C.Colden May 17 '13 at 18:46
  • I think that's for adding an element to the table of content what I want is to add a table of abbreviation – Yahya KACEM May 17 '13 at 22:27
  • I also just added acronyms with >insert -> nomenclature entry but at the place where they should be displayed. I didn't used the second command you mentioned. Update: I just tried it and it worked fine. I am not sure why you are using the second command... – C.Colden May 18 '13 at 11:14
  • What you mean it worked fine, did it generate a table of abbreviation? – Yahya KACEM May 18 '13 at 12:59
  • Thanks, that did it "Tools > Preferences > Output > LaTeX" set to "makeindex -s nomencl.ist" maybe put this as an answer so I can accept it. – Yahya KACEM May 18 '13 at 21:02
2

A "nomenclature entry" is translated by LyX to a \nomenclature command of the package "nomencl". The creation of the list of acronyms by "Insert > List/TOC > Nomenclature" invokes the program "makeindex" (of the TeX distribution).

One can tweak the call of "makeindex" or could even replace it by changing the field "Nomenclature command" under "Tools > Preferences > Output > LaTeX". For LyX 2.0.x, the default setting of this field should be makeindex -s nomencl.ist. This value might have been lost somehow...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.