4

I use Windows 7. I have a project open and a file from that project. I want to split the window using Window->Split to edit one part of the document while seeing another one. The split option is shaded (as in non-clickable). Any idea why?

Also, when I have many windows open the buttons Tile Horizontally and Tile Vertically do nothing. Any idea of what I'm doing wrong?

  • I'd welcome you again, but I hope you already feel welcomed! Please, only one question per post. Take a look at our FAQ. – Sean Allred May 18 '13 at 4:12
  • 1
    :-) I kept them together because they are both in the same menu and clearly related. I'm sure solving one will solve the other one. – Jesus Martinez Garcia May 18 '13 at 4:15
  • Thinking about it more, you're very likely right. Have you tried opening more than one document? Just a random guess, but it may be that you can't have two windows if you don't have two documents to view (even if one should view the output of the other). It is beta, after all. – Sean Allred May 18 '13 at 4:19
  • yes, I need to open a second document for the commands tile horizontally/vertically to make sense, but they don't work. If I try to open the same document twice (I thought of that) it does not open a new document because all in all the document is already opened. Given that the window environment is usually controlled by Windows libraries I start to suspect it might just be a bug, but I thought I would give it a try here before bugging the developers, in case it isn't a bug. – Jesus Martinez Garcia May 18 '13 at 4:22
  • I meant open two separate documents – Sean Allred May 18 '13 at 4:23
2

This surely sounds like a bug, which you should report. Regardless, here's how to achieve what you're after (to some extent) when in "document tab" view.

With TeXnicCentre 2.0 Beta 1 a drag-and-drop of the opened files initiates the tiling. So, given a setup like

enter image description here

click on LaTeX3 and drag it into the code just below it to make it tile. Dragging it to the bottom provides a horizontal tiling

enter image description here

while dragging it to the right/left provides a vertical tiling

enter image description here

To restore the tiling, drag it back to the tabs of the files listed files. Out of "document tab" view (View > Document Tabs > Off)

enter image description here

tiling works as expected, both vertically

enter image description here

and horizontally

enter image description here

| improve this answer | |
  • Wow, that is great and it solves the tiling. Thanks a lot. The buttons are still dumb, so it is definitely a bug. I guess you have the same problem as I do in the splitting? You are using the same version as I am and your windows look a lot as Windows 7 to me. If you do, please let me know. It is driving me crazy to write an appendix at the same time as a chapter. – Jesus Martinez Garcia May 18 '13 at 7:45
  • 1
    @Jesus: I am using the same version as you. As mentioned in my updated answer, the "Document tab" view is the culprit that fixes the view and avoids tiling. If you turn of "Document tab" view, then you can cascade and tile the windows to your liking. – Werner May 22 '13 at 22:24
  • Hi, wow I didn't know about the 'view' options. Thanks. Unfortunately they don't solve the splitting problem. Do you also have it? Thanks a lot for your answers! – Jesus Martinez Garcia May 24 '13 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.