4

I want to remove the self-reference of the ToC in Latex book class as in the picture below

enter image description here

Can you help me?

  • Please add a minimal working example (MWE) that illustrates your problem. You clearly are using hyperref package and that is not reflected in any way in your question. – zeroth May 19 '13 at 13:33
13

The class book does not include starred chapters into the table of contents. The \tableofcontents and \listoffigures use a starred chapter internally, therefore I guess that you are using package tocbibind that includes both \tableofcontents and \listoffigures in the table of contents. The first can be disabled by option nottoc:

\documentclass{book}
\usepackage[nottoc]{tocbibind}
\begin{document}
\frontmatter
\tableofcontents
\listoffigures
\mainmatter
\chapter{Introduction}
\end{document}

Result

Class CUEDthesis

The class contains:

\usepackage{tocbibind}

Thus my guess is quite correct. ☺

Since the option nottoc cannot be given after loading the class (except using an internal \@dotoctocfalse), the option can be given before:

\PassOptionsToPackage{nottoc}{tocbibind}
\documentclass{CUEDthesisPSnPDF}
4

I don't get a Contents line in the following MWE

\documentclass{book}
\usepackage{lipsum}
\begin{document}
    \tableofcontents%
    \chapter{First}
    \lipsum%
    \chapter{Second}
    \lipsum%
\end{document}

Do you have a line that is something like

\addcontentsline{toc}{chapter}{Contents}

near to \tableofcontents? The \addcontentsline will add an entry to toc at the the chapter level called Contents.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.