3

I have knowledge about 'Kile' more or less. Now I am using 'Texmaker'. But there is a problem in it. In Kile when we write \begin{env} it automatically write \end{env} from the following :

Settings => Configure Kile => LaTeX => Environments => making tick mark on "Automatically complete \begin{env} with \end{env}" we can set it. But in 'Texmaker' automatic environment is not working. How can I do so.

3

In Texmaker, you can go to User>Customize Completion and set the \begin{...} and \end{...} that you often use. For example, the tikzpicture environment is not set by default. As I often use it, I have added

\begin{tikzpicture}

and

\end{tikzpicture}

Then, when I type \begin{tik , Texmaker gives me \begin{tikzpicture}, I hit tab and I have the \begin{tikzpicture} and \end{tikzpicture} added to my document.

You may find more information at this post: Customize auto-completion in Texmaker

  • I am using 'Texmaker 1.9.9'. There is no 'Customize Completion' option under 'user'. There are two options under 'user' namely, 'User Tags' and 'User Commands'. – Md Kutubuddin Sardar May 20 '13 at 8:30
  • 1
    I'm using texmaker 3.4.1 under mac os. The last version is 4.0.2 and is available here : download for all platforms. An update should be helpful. – LouisG May 20 '13 at 8:37
  • My system is 'ubuntu 10.04'. Will this version of ubuntu support'TeXmaker 4.0.2' ? – Md Kutubuddin Sardar May 20 '13 at 8:46
  • I'm not very used to ubuntu but I think that the software center should give you the answer. – LouisG May 20 '13 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.