8

Here's a minimal working example:

\documentclass{article}
\usepackage[T1]{fontenc}
\begin{document}
\texttt{>>}
\end{document}

This makes a right guillemet. I'd like a double chevron. If I comment out the fontenc package, I indeed get a double chevron. Any advice?

3
  • With T1 fontend you should get a right guillemet, but without it you shouldn't be getting a double chevron; are you sure you haven't left something out?
    – Sam Whited
    May 20, 2013 at 14:57
  • A "chevron" is an upside-down v - are you sure that's what you mean? Or do you just mean a "greater-than" symbol? May 20, 2013 at 15:51
  • I mean the "greater-than" symbol.
    – oleks
    May 20, 2013 at 15:59

2 Answers 2

6

You can break up the two > symbols by putting {} between them, like this:

\documentclass{article}
\usepackage[T1]{fontenc}
\begin{document}
\texttt{>{}>}
\end{document}
1
  • Thanks! Works for me, but I find it annoying to have to do it every time...
    – Andreina
    Mar 17, 2016 at 16:04
6

You can use the microtype package:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage{microtype}

%% disable the << and >> ligatures in typewriter type
\DisableLigatures[<,>]{encoding=T1,family=tt*}

\begin{document}
\texttt{<<abc>>}

<<abc>>
\end{document}

enter image description here

3
  • This works, but it changes the font of the whole document.
    – Andreina
    Mar 17, 2016 at 16:03
  • @Andreina In what sense?
    – egreg
    Mar 17, 2016 at 17:32
  • to be honest, it was imperceptible to the naked eye, but I think it was only changing the spacing. Anyway, I managed to fix it by adding this: \usepackage[protrusion=false,expansion=false]{microtype} Either it's a normal problem or it happened because I'm using the lncs style.
    – Andreina
    Mar 19, 2016 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.