6

I am having trouble using SabonLT which is a Postscript Type 1 Outline font. I have the font installed as a system font (as described here) rather than a local font. I'm running LuaLaTex on Mac OSX.

I have checked in /Users/<username>/Library/texlive/2012/texmf -var/luatex-cache/generic/names/otfl-names.lua but indeed no Sabon font is listed there.

I have tried both with and without the path specification in the fontspec call: \setmainfont[Path=/Library/Fonts/]{Sabon LT}. (Though there is no way to specify the extension because Postscript Type 1 fonts don't have one.)

But no matter what I do I get the following error: fontspec error: "font-not-found".

15
  • 7
    I don't think that luaotfload (used by fontspec) handles type1 fonts - at least not the version from texlive 2012. You will have to create a tfm file and use it in the "standard" way. Commented May 20, 2013 at 18:04
  • 2
    type 1 fonts (pfa and pfb) aren’t indexed by luaotfload. They should, however, work as absolute paths (e.g. \font\foo=[/path/to/font.pfa], idk how to do that with fontspec) or if the file can be found by kpathsea. Commented May 20, 2013 at 18:35
  • @phg doesn't work here (tl2012, lualatex)
    – topskip
    Commented May 20, 2013 at 20:05
  • 1
    @cfr Can LuaTeX also make use of the relevant .afm files? -- Yes, that functionality is exposed by means of the function fontloader.apply_afmfile(). Though AFAIR the Luaotfload fontloader does its own AFM parsing and applies them similar to Opentype features. See the source for the gory details. Commented Nov 24, 2015 at 22:33
  • 1
    @cfr AFM files are indexed along with the other registered formats when building the names database but not by default. That behavior can be overridden by passing an appropriate --formats=… option to luaotfload-tool or by setting the configuration option. (The reason for not including them by default is that TeX distros ship with tons of Type1 font files that only slow down the loading and are rarely used with Luatex.) Commented Nov 24, 2015 at 23:04

0

You must log in to answer this question.

Browse other questions tagged .