I am using beamer to write a presentation which is split into several parts. The title of one part is too long to fit on one single line, so there should be a line break. However the command \partpage displays the text on one single line. I have the impression that the issue is related to \insertpart, since the same behavior happens as well for this command.

Furthermore I noted that the problem disappears if I use pdflatex, which is however not possible for my presentation since I have many .eps figures.

Here is a minimal example which reproduces the problem:

\documentclass{beamer}

\begin{document}

 \part{very very very very very very very very very very very very very very very long part title}
 \frame{\partpage}
 \frame{\insertpart}

\end{document}

Any help is appreciated.

  • Welcome to TeX.SX. You might have a look to our start page: it will help you to familiarize with the site. – Claudio Fiandrino May 21 '13 at 10:19
  • You can try \documentclass[hyperref=breaklinks]{beamer} but imho it would be better to use pdflatex and \usepackage{epstopdf}. This will convert your eps-files on the fly (if your system is not to old). – Ulrike Fischer May 21 '13 at 11:23
  • Using the option hyperref=breaklinks solved the problem. \usepackage{epstopdf} did not work, maybe my system is indeed too old. – user31028 May 21 '13 at 11:53

You can try \documentclass[hyperref=breaklinks]{beamer} but imho it would be better to use pdflatex and \usepackage{epstopdf}. This will convert your eps-files on the fly (if your system is not to old).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.