1

IPE won't save my file as an .eps whenever I try to insert any text labels.

Here's what I have inserted as the preamble:

\usepackage{graphicx}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{amsmath}
\usepackage{latexsym}
\usepackage{mathrsfs}

Whenever I try to save, I get the following error:

Something is wrong with the PDF file generated by Pdflatex. Please consult the stderr output to identify the problem.

Any ideas where I'm going wrong?

I'm working on a mac if that's relevant.

  • I'm working on a mac if that's relevant. – James Shapiro May 23 '13 at 2:10
  • 1
    Edit: resolved. For reference for anyone else who runs into this problem, you may have to add \pdfobjcompresslevel0 to your preamble. – James Shapiro May 23 '13 at 2:55
  • Which Ipe version do you use? – Jan Hlavacek May 23 '13 at 4:04
  • I use version 7, but I fixed the problem (see above). – James Shapiro May 23 '13 at 4:43
  • Sure, I understand that you use the well known workaround, but this is not suposed to happen in recent versions of Ipe at all. I suppose that you use Ipe version 7.0.10 or older. Upgrading to a recent version should fix it without having to disable pdf compression across objects in the preamble. If it doesn't, you should submit a bug report. – Jan Hlavacek May 23 '13 at 4:52
2

In TeXLive 2010, and probably other TeX distribution released at that time, the default PDF compression changed, so that Ipe was no longer able to read the PDF files generated by LaTeX.

Ipe version 7.0.11 fixed that problem. Upgrading to a newer version of Ipe should help.

If for some reason you do not want to (or cannot) upgrade, you can insert \pdfobjcompresslevel0 into the Ipe document preamble ("Edit" -> "Document Properties" and change "Latex preamble"). That will make LaTeX use old pdf compression scheme.

See also this Ipe FAQ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.