Compiling a beamer project, I get the following error:

mktexpk: /home/matthieu/.texlive2012/texmf-var/fonts/pk/ljfour/public/cm/cmss8.525pk: successfully generated.
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+525/600 --dpi 525 mathkerncmssi8
mktexpk: don't know how to create bitmap font for mathkerncmssi8.
mktexpk: perhaps mathkerncmssi8 is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

!pdfTeX error: /usr/bin/pdflatex (file mathkerncmssi8): Font mathkerncmssi8 at 
525 not found
 ==> Fatal error occurred, no output PDF file produced!

Reading some answers, I added \pdfmapfile{+sansmathaccent.map} to my .tex file and the compilation worked but I want to solve the problem.

Hence I also tried to run updmap-sys and mktexlsr but I got lost between the locations of the map files...

I copy below the output of these two commands. If anyone can help me...

[root@localhost matthieu]# updmap-sys /usr/share/texmf/fonts/map/pdftex/updmap/pdftex.mapupdmap is using the following updmap.cfg files (in precedence order):   /etc/texmf/web2c/updmap.cfg dvips output dir: "/var/lib/texmf/fonts/map/dvips/updmap" pdftex output dir: "/var/lib/texmf/fonts/map/pdftex/updmap" dvipdfmx output dir: "/var/lib/texmf/fonts/map/dvipdfmx/updmap" pxdvi output dir: "/var/lib/texmf/fonts/map/pxdvi/updmap"

updmap is creating new map files using the following configuration:   LW35 font names                  : URWkb (/etc/texmf/web2c/updmap.cfg) prefer outlines                  : true (/etc/texmf/web2c/updmap.cfg)  texhash enabled                  : true   download standard fonts (dvips)  : false (/etc/texmf/web2c/updmap.cfg)   download standard fonts (pdftex) : true (/etc/texmf/web2c/updmap.cfg)   kanjiEmbed replacement string    : noEmbed (default)   kanjiVariant replacement string  :  (default)   create a mapfile for pxdvi       : false (default)

Scanning for LW35 support files  [  3 files] Scanning for MixedMap entries    [ 37 files] Scanning for KanjiMap entries    [  0 files] Scanning for Map entries         [ 73 files]

Generating output for dvipdfmx... Generating output for ps2pk... Generating output for dvips... Generating output for pdftex...

Files generated:   /var/lib/texmf/fonts/map/dvips/updmap:
       11448 2013-05-22 16:04:24 builtin35.map
       15911 2013-05-22 16:04:24 download35.map
      324599 2013-05-22 16:04:24 psfonts_pk.map
      577080 2013-05-22 16:04:24 psfonts_t1.map
      577075 2013-05-22 16:04:24 ps2pk.map
          14 2013-05-22 16:04:24 psfonts.map -> psfonts_t1.map   /var/lib/texmf/fonts/map/pdftex/updmap:
      577082 2013-05-22 16:04:24 pdftex_dl14.map
      575509 2013-05-22 16:04:24 pdftex_ndl14.map
          15 2013-05-22 16:04:24 pdftex.map -> pdftex_dl14.map   /var/lib/texmf/fonts/map/dvipdfmx/updmap:
         281 2013-05-22 16:04:24 kanjix.map

Transcript written on "/var/lib/texmf/web2c/updmap.log". updmap: Updating ls-R files.

[root@localhost matthieu]# mktexlsr mktexlsr: Updating /etc/texmf/ls-R...  mktexlsr: Updating /usr/share/texmf/ls-R...  mktexlsr: Updating /usr/share/texmf-dist/ls-R...  mktexlsr: Updating /usr/share/texmf-local/ls-R...  mktexlsr: Updating /var/lib/texmf/ls-R...  mktexlsr: Done.
  • Check if the pdftex.map written by updmap-sys is actually the one used by pdftex (the path is in the log-file). – Ulrike Fischer May 23 '13 at 14:14
  • 1
    Welcome to TeX.SX! You may have a look on our starter guide. – Corentin May 23 '13 at 14:27
  • cat GT_Deneufchatel.log | grep pdftex.map yields {/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] and updmap-sys generates these files: /var/lib/texmf/fonts/map/pdftex/updmap: 577082 2013-05-22 18:39:51 pdftex_dl14.map 575509 2013-05-22 18:39:51 pdftex_ndl14.map 15 2013-05-22 18:39:51 pdftex.map -> pdftex_dl14.map – matthieuP78 May 23 '13 at 16:40
  • In the output of the compilation with pdflatex appears the location /root/.texlive2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map. Is it related to my problem ? – matthieuP78 May 23 '13 at 16:48
  • The mathkerncmss10 font is used by a recent version of the sansmathaccent. Maybe you've improperly installed it. – egreg May 23 '13 at 16:52

It looks like you are using a distribution which either does not properly activate installed map files.

First, your invocation of updmap is wrong. You cannot call updmap with the full path of a map file, please see the man page of updmap --help for correct syntax. The normal solution would be to call

updmap-sys --enable Map sansmathaccent.map

which should be enough. Since your distribution uses only /etc/texmf/web2c/updmap.cfg you also could edit this file and add one line

Map sansmathaccent.map

followed by a call to updmap-sys.

In case your distribution installed sansmathaccent.map, you should write a bug report to the distribution as they have not properly set up the map activation system (I really should write that article on how to distribute TeX Live!!!)

  • I have same problem, but I do $ updmap --enable Map sansmathaccent.map in Fedora 22, Texlive 2014 – user85811 Sep 1 '15 at 8:35
  • updmap creates config files within the home directory of the calling user, These files will take precedence over system files, even if the system files are newer. – norbert Sep 2 '15 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.