6

I have a list of references created in BibTex and now I'm trying to put in in LyX, to then create a PDF.

I tried doing: Insert -> List -> BibTex Bibliography and I get a grey box saying BibTex Generated Bibliography. However, now when I try to create a pdf, nothing shows up in my bibliography.

I had to put

\bibliographystyle{plain}
\bibliography{}

as a code in front of my grey box, or else I get an error.

Any ideas with what could have gone wrong, with these two problems?

  • 2
    Welcome to TeX.SX! You may have a look on our starter guide. – Holene May 24 '13 at 11:32
  • 3
    You should be writing \bibliography{xxx} where xxx.bib is the name of your bibtex file. Also your document needs to include some \cite commands, or \nocite{*} to just list the whole bibliography. – Andrew Swann May 24 '13 at 11:44
  • Did you add your bib-file, when doing Insert BibTeX bib? What error do you get? – Torbjørn T. May 24 '13 at 12:22
  • I have \bibliography{bibliography} now and I have some citations as well. when I click on the grey box my bibliography also shows up. but the actually pdf bibliography is still empty. any other ideas? the style I'm trying to use is APA, but that shouldn't matter I guess? – Steven May 25 '13 at 11:05
  • does it matter which folder my bibliography is in when I write \bibliography{bibliography}? – Steven May 25 '13 at 11:11
4

You need a *.bib file as a BibTeX database.

Selecting the context menu ("right clicking") over your "BibTeX Generated Bibliography" will open a dialogue box that will allow you to navigate to and select your *.bib BibTeX file.

Then, on the LyX menus

Insert | Citation

The citation will be used to populate the list of references in the Bibliography.

|improve this answer|||||
0

Maybe this is stupid, but in Lyx I noticed that when opening the BibTex catalogue dialog box (the one with the list of bibtex bibliography catalogues where you can manage them), when selecting the bibliography entry in the list, you should make sure that the Style text box is not empty! That was the problem for me :) I selected "plain" as bibliography style and it worked. I think that is a Lyx bug that doesn't ovverride the bibliography style whith the standard style defined in the document options if this is not defined.

|improve this answer|||||
  • 1
    Welcome to TeX.SX! Your post might be an answer to this 'old' question, but could you elaborate on your post please. – user31729 Sep 19 '14 at 14:26
  • A LyX bug or missing feature? If you think it is either, please post on lyx.org/trac with an example file. – scottkosty Sep 19 '14 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.