3

I receive the following warning and managed to figure out that these were due to some interplay between the hyperref package and the commands \tableofcontents, \listoftables and \listoffigures (the command \afterpreface essentially does \tableofcontents, \listoftables and \listoffigures). I have \hyperref package as the last package added in my preamble and with the following options:

\usepackage[plainpages=false,pdfpagelabels]{hyperref}

How do I get rid of these warnings?

(/usr/share/texmf/tex/latex/lm/omslmr.fd)pdfTeX warning (ext4): destination wit
h the same identifier (name{page.}) has been already used, duplicate ignored
<to be read again> 
                   \relax 
l.125   \afterpreface
                     [1] (./temp.toc)pdfTeX warning (ext4): destina
tion with the same identifier (name{page.}) has been already used, duplicate ig
nored
<to be read again> 
                   \relax 
l.125   \afterpreface
                     [2] (./temp.lot)pdfTeX warning (ext4): destina
tion with the same identifier (name{page.}) has been already used, duplicate ig
nored
<to be read again> 
                   \relax 
l.125   \afterpreface
                     [3] (./temp.lof
Underfull \vbox (badness 2189) has occurred while \output is activepdfTeX warni
ng (ext4): destination with the same identifier (name{page.}) has been already 
used, duplicate ignored
<to be read again> 
                   \relax 
l.12 ...sponds to $10^4$ sec/m.}}{28}{figure.2.10}
                                                   [4])pdfTeX warning (ext4): d
estination with the same identifier (name{page.}) has been already used, duplic
ate ignored
<to be read again> 
                   \relax 
l.125   \afterpreface
                     [5]pdfTeX warning (ext4): destination with the same identi
fier (name{page.}) has been already used, duplicate ignored
<to be read again> 
                   \relax 

1 Answer 1

4

Probably you are using something like \pagenumbering{gobble}. Since the page number is also used for destinations and page labels. If you want to suppress the page number on pages that automatically set page style plain (page that starts the chapter/table of contents/...) then you can redefine the page style plain as described in section "7 Redefining plain style" in the documentation for package fancyhdr:

\usepackage{fancyhdr}

\fancypagestyle{plain}{%
  \fancyhf{}% clear all header and footer fields
  \renewcommand{\headrulewidth}{0pt}%
  \renewcommand{\footrulewidth}{0pt}%
}

For other pages (title page, ...) page style empty can be used. Also the page anchors can be disabled by \hypersetup{pageanchor=false} and reenabled by using true.

You must log in to answer this question.