3

I made a table with the tabular environment and I wanted to continue writing (under it) but the words are moved to the next page. I used:

\makeatletter
\setlength{\@fptop}{0pt}
\setlength{\@fpbot}{0pt plus 1fil}
\makeatother

to move the table to the top of the page. I don't know if this has something to do with this error. Or are there any commands under the table before continue writing?

3

If \@fpbot is having an effect then LaTeX has placed the float on a float page that as the name suggests only contains floats. Probably if you write sufficient text then LaTeX will automatically be able to place it at the top of a text page above the text of the document.

You can prevent LaTex from using float pages by using \begin{table}[t] so the float has to go at the top of a normal page unless flushed out with \clearpage but over use of such optional arguments constrains LaTeX's float positioning and can easily mean no float may be positioned so they will be held up to end of document.

  • I see, but after ending the table, where shall I continue write? Use \par\bigskip after the text before and continue writing or after \end{table} ? – abdu May 24 '13 at 20:47
  • you shouldn't need \par or \bigskip. You should really always include an example document on every question, it makes it much easier to help. If the text is part of the float, a caption or legend or attached note of some kind it goes inside the table environment and floats with it (and may be on the float page) If the text is part of the main document flow just enter the text as usual don't do any manual spacing commands as they will be in the wrong place as LaTex will move the float depending on page breaking – David Carlisle May 24 '13 at 20:50
  • 1
    @abdu -- you can force the processing of all previous floats with \clearpage before you input the table (with \begin{table[t] as suggested by david). then leave a blank line and just continue typing whatever text you want to appear following the table. the vertical space between table and text will be taken care of automatically by settings in the document class. it's generally not recommended to tinker with those settings unless you have experience creating or modifying document classes. (if the result is not what you expect, you can always ask, with a minimum example.) – barbara beeton May 24 '13 at 20:53
  • @barbarabeeton this works, thank you! To be honest I only understand a little about all these commands, it's sometimes like Chinese for me. That's why I just copy paste commands. That's not good I know but I'm using Latex since 3 weeks so I still need some time. – abdu May 24 '13 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.