I am very new to LyX (no LaTeX background whatsoever) and cannot manage to properly insert citations. The problem is, within LyX the citation seems ok [Sayer], but when I render the PDF, I only get [?].

I have found similar problems, but with that information I can't make it work.

LyX: Question mark [?] instead of reference number after installing new .bst file
Question mark or bold citation key instead of citation number

As I understand, the two possible problems are unicode related, and some communication problem between BibTeX and LyX.

I can insert citations from LyX, which means that at least it knows where the DB is, and apparently "understands" it. It's just a test, but this is what the DB contains (no strange unicode)

  author={Natalie J. Sayer},
  title={Lean for Dummies}

And... when I check the log Document > LaTeX Log, I get the following Warning:

LaTeX Warning: Citation `Sayer' on page 1 undefined on input line 124.

Which yes, makes all the sense of the world, but I don't know what to do next.


I have realized that I get different mistakes if I try to create the PDF from the "parent" file or from the "child" (i.e.: lyx document within lyx doc). From the child doc, the PDF is created with that [?], but from the parent doc, it does not even compile. Apparently there is one mistake per reference I have introduced in the children docs:

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

Maybe this helps.

closed as too localized by Marco Daniel, Heiko Oberdiek, Claudio Fiandrino, Thorsten, Mensch Jun 3 '13 at 10:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What is the citation style when you right-click the citation and choose settings...? Also try changing Document->Settings...->Bibliography to use Natbib instead. – juliohm May 25 '13 at 17:18
  • It shows [#ID]. I tried with Natbib and just shows the same error in different formats like (?). – bgusach May 25 '13 at 17:20
  • Try using Natbib instead and see if the output is OK. – juliohm May 25 '13 at 17:22
  • Now the error report says: Package natbib Warning: Citation 'Sayer' on page 1 undefined on input line 125. – bgusach May 25 '13 at 17:25
  • 1
    \citep is defined by natbib, so the error in the master document is probably caused by natbib not being used. – Torbjørn T. Jun 1 '13 at 22:53