3

I am pretty new to LyX, and have no expirience with LaTeX. I'm writing my master's thesis in LyX, though, and I'm supposed to turn it in in a week. I want my bibliography to be "apa-ish", and have set the bibliography style to apalike.

The problem is, when i try to export my document to pdf format, I get an error message saying Package natbib Error: Bibliography not compatible with author-year citations.

What's wrong?

I'm using Jabref to organice my references, by the way, but i doubt that has got anything to do with it.

Edit: I should probably add that I do not face any such problems when using author-year citations with the plainnat bibliography style.

7
  • Welcome to TeX.SX! You may have a look on our starter guide.
    – jub0bs
    May 26, 2013 at 18:06
  • @Jubobs Thanks! Did I do something wrong here?
    – Fisla
    May 26, 2013 at 18:26
  • No; nothing to worry about :) That was simply a warm welcome to TeX.SE, and a link to help you familiarise yourself with how the site works.
    – jub0bs
    May 26, 2013 at 18:27
  • 1
    Try changing the settings under Document > Settings > Bibliography. If that doesn't work, post a minimal example.
    – scottkosty
    May 26, 2013 at 22:11
  • @scottkosty I need to have author-year citations, and natbib author-year is, as far as I can see, the only option that allows for that. But I can change the settings and then change them back, if that might work somehow?
    – Fisla
    May 27, 2013 at 8:25

1 Answer 1

2

It seems the solution this time was to simply remove the bibliography from my table of contents, then save and close LyX, then open the document again and reinsert the bibliography, before saving, closing and opening the document once more. I have no idea why it worked, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.