2

I am using LyX 2.0.3, and I usually type my documents (my lecture notes, mainly) in french.

Now, I have to write a paper in english, I can't get the label names of the AMS Theorems package to be in english and not in french. They appear in french in the user interface - which, I guess, is the normal behavior - and they are still in french in the PDF. This is weird, because:

  • the language of my document is setup as « English »,
  • the language pack option in « Documents parameters » → « Language » is « Automatic » (but I have tried all the other options and none is working),
  • and LyX automatically uses babel.

When I export in LaTeX, the following lines are added :

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
\theoremstyle{plain}
\newtheorem{thm}{Théorème}
  \theoremstyle{definition}
  \newtheorem{defn}[thm]{Définition}
  \theoremstyle{remark}
  \newtheorem*{rem*}{Remarque}
  \theoremstyle{plain}
  \newtheorem{cor}[thm]{Corollaire}
  \theoremstyle{plain}
  \newtheorem{prop}[thm]{Proposition}
  \theoremstyle{plain}
  \newtheorem{fact}[thm]{Fait}

I do not know what adds them. If I manually replace them by their english equivalent, it works fine. So, is there a better solution than to systematically add all the correct definitions in the preambule? Additionally, should I send a bug report to the Lyx developers?

  • 3
    Please try the latest version of LyX before sending a bug report. If you happen to use Ubuntu, see here. If you still have a problem, post a LyX minimal example with your bug report – scottkosty May 28 '13 at 5:22
  • If I use Debian Sid, do I have another option to get the latest version than compile it by hand? – user1536048 May 29 '13 at 0:33
  • No. I would suggest you send a minimal example .lyx file to lyx-users@lists.lyx.org. One thing to try is to select all, right-click, and mark the language as English. Also, is there a typo in your question? You say that the PDF output is English. Isn't this what you want? Or you are asking about how it shows up in LyX (but if, so then why do you put the preamble?). I'm confused. – scottkosty May 29 '13 at 8:48
  • You are right about the typo, I just fixed it. I will send a minimal example to lyx-users@lists.lyx.org in a couple of days if I do not have any answer until then. By the way, I did not put the preamble that you can manually add in LyX, because it is empty. I just tried to export my .lyx file into a .tex file to see if I could see where the problem came from. – user1536048 May 30 '13 at 0:23
  • Either this is a LyX bug, or some part of your document must be (incorrectly) set to French. Try this: éditer > sélectionner tout, éditer > style de text > Personnalisé > Langue: Anglais – scottkosty May 30 '13 at 7:26
1

For archival purposes, the solution (by Georg Baum) is here. I paste it below:

Therefore, I guess that you used the translated layout files from wiki.lyx.org for 1.6.x (LyX only got native support for layout translations in the output with version 2.0.0), and that these layout files are still lying around and being used. I guess that the problem will go away if you rename ~/.lyx/layouts to ~/.lyx/layouts-tmp and reconfigure. If that helps, you can move those layouts back to ~/.lyx/layouts which you want to keep.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.