Everytime I compile my file, I get a message from TeXstudio saying

The logfile is very large (> 2 MB) are you sure you want to load it?

This is mostly because I am updating the bibliography, while to a large extent the .bib file is not correctly formatted (it is simply an output from Endnote actually).

My question is: Is there any way for me to avoid getting the warning from TeXstudio and permanently assign that I want to load the log file? (otherwise, I am not able to see the Errors, and the bibliography is not even made).

Edit: It seems like the error is not coming from the bibliography after all, but from a lot of messages like these:

    {leaving hbox group (level 16) entered at line 4}
    {leaving simple group (level 15) entered at line 4}
    {leaving hbox group (level 14) entered at line 4}
    {leaving math choice group (level 13) entered at line 4}
    {entering math choice group (level 13) at line 4}

Thanks in advance

  • 3
    You can try commenting out the bib and fixing the tex related errors and then bring in one bib item at a time to see if it is error free, and if not, fix it. – dustin May 28 '13 at 16:55
  • How badly formatted must your .bib file be to produce so large a .log?! If it is (only/chiefly) due to the .bib file, just fix it and stop running your .tex file until it is done.... If EndNote has provided a faulty file, I suspect the errors are of the 'repeating' kind, and that many could be fixed through a reasonable use of search-and-replace kind of edits. – jon May 28 '13 at 19:08
  • @jon I was suspecting it was from the .bib file, because to create it I only exported all (>15000) references from my Endnote file. The problem in fixing these errors through search-and-replace is that I want to keep both my .bib and Endnote libraries in sync: so whenever I update endnote, I have to export everything again, which would revert any fixes I had done in the .bib file before – Sosi May 28 '13 at 19:13
  • Do you really include 15000 references in your latex file? By the way biblatex has some experimental support for endnote, so there might be no need to export you endnote library to .bib, – Guido May 28 '13 at 19:22
  • @dustin ok, after doing what you suggested, I still get the log size warning. I get some errors due to the citations that are not being inserted (i.e., Texstudio is not recognizing the \citep commands), and a couple of errors of paragraph size (Underfull \hbox (badness 10000)...). Yet, this does not explain the huge log file.. Look at the edit I made in post, maybe it helps. – Sosi May 28 '13 at 19:23
up vote 5 down vote accepted

LaTeX (and some packages) provide a large array of \tracing... macros. These macros include debugging information in the .log file that could potentially bloat the file. Remove them (either manually, or through an option within TeXStudio that has been enabled) to reduce the size of your .log and it will also increase the speed at which you compile.

  • Indeed, I had set \tracinggroups=1 in the preamble of my document. This was producing the big list in the logs. Thanks! – Sosi May 28 '13 at 19:46

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.