11

I just updated to the latest version of TexShop and now my inverse search (from the pdf to the source) does not work anymore. Neither with command+click nor with right click -> sync. It used to work flawlessly until before the update. The options that I have in preferences -> engine are the default options, i.e.: "pdflatex --file-line-error --syncTex=1" (I only use pdflatex). Any suggestion?

  • 1
    In the Typesetting preference panel, you should have SyncTeX (TeX ≥ 2010) chosen. Is it? What version of the Mac OS are you running? – Alan Munn May 30 '13 at 18:58
  • Hi, yes, I thought I wrote it, but I must have forgotten. However, it was just a matter of case sensitivity (see egreg answer). – mic May 30 '13 at 20:29
12

I quote from the Release Notes of version 3.18

Version 3.18 has only a single change:

TeXShop contains an obsolete sync method called Search Sync, and a modern replacement by Jerome Laurens called SyncTeX. In recent versions of TeXShop, the obsolete Search Sync from the Preview Window to the Source Window randomly hangs, making TeXShop unresponsive This was supposed to be fixed in version 3.17, but it wasn't. Unfortunately, when the modern SyncTeX cannot find a match, it calls the old Search Sync, so SyncTeX can indirectly hang as well.

It is silly to waste time on an obsolete method, so in TeXShop 3.18, Search Sync from the Preview Window to the Source Window is disabled and does nothing. Most users will notice no change. Users who misconfigured SyncTeX will lose synchronization.

Users should check that

1) in TeXShop Preferences under the Typesetting tab, the "Sync Method" is set to SyncTeX;

2) in TeXShop Preferences under the Engine tab, the two configuration lines for "pdfTeX" each contain the following flags

--file-line-error --synctex=1

3) in TeXShop Preferences on the same page, the two "TeX + dvips + distiller" lines contain the following instruction

--extratexopts "-file-line-error -synctex=1"

The easy way to do this is to push the four "Default" buttons beside these four entries.

(The doc uses --syncTeX=1, but it's wrong, so I edited it in the quotation.)

  • 1
    Hi, thanks for the reply. I actually went into the logs of a sample compilation, and I saw that the --syncTeX=1 option is not recognized. The engine is case sensitive, and it wants it all small case, like this: --syncteX=1 I remember that I had it like that, and I changed it after reading the Release Notes! As a side note, while the "default" button works, the "set default values -> regular" at the bottom of the preferences window does not work. Thanks! – mic May 30 '13 at 20:26
  • 3
    This solution is not working for me. – Antonio Sesto Dec 2 '15 at 14:59
  • 1
    For me neither. Any other suggestions? – Casimir Aug 9 '16 at 4:04
  • @Casimir What version of TeXShop are you running? What method for getting a PDF file? – egreg Aug 9 '16 at 7:41
  • Ah this is amazing, really great relief! I was already considering downgrading to an older Version of TeXShop. Anybody who have problems with these options: close & reopen the app and then most importantly cmd-t to typeset it! – Damian Vogel Dec 16 '18 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.