Despite having gone through

Configure TexnicCenter with something else than Adobe Reader X

and having looked at the TeXnicCenter + Sumatra Tutorial, there seems to some little changes for TeXnicCenter version 2.0 as of May 2013. How can I make TeXnicCenter 2.0 to work with Sumatra?

  • 1
    Can you add a real question? – karlkoeller May 31 '13 at 10:18
  • @karlkoeller I don't have a question, I simply used the answer your own question option, because I recently came up with this issue. Unfortunately, the answers contained in the site are outdated. – Mario S. E. May 31 '13 at 10:54
  • Sorry, I thought that to answer your own question one would have to post the question and then to post an answer. But I'm quite new here... – karlkoeller May 31 '13 at 11:37
  • 1
    @karlkoeller you are right, Mario wrote only the question and no answer. Mario can you please add an answer and change the question? Or to left a comment behind that questions showing wrong informations? – Kurt May 31 '13 at 12:14
  • Please skip to StackJack 's comment of Aug 23rd '18 below the accepted answer – KJO Oct 6 at 0:52
up vote 42 down vote accepted

Follow all the steps mentioned in the TeXnicCenter + Sumatra Tutorial, but keep in mind these few things:

  1. In the (La)TeX tab / (La)TeX compiler section / Command line arguments to pass to the compiler bar, you should write: -synctex=-1 -interaction=nonstopmode "%Wm"

  2. In the Viewer tab / Executable path section, what should be written is: "C:\Program Files\SumatraPDF\SumatraPDF.exe" -inverse-search "\"C:\Program Files\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\"". Please note:

    1.1 What should be written is a complete line, with spaces between line breakings (it just doesn't fit entirely here to show).

    1.1.1 The path could be different in your computer (e.g., your path for the executable file could be in "C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe") or depending on your system's language could be something like C:\Programme\...

    1.2 If you copy + paste from Adobe Reader from the tutorial, it is not going to work, as it seems to copy the ' as ` instead.

    1.3 The new executable file for TeXnicCenter 2.0 is actually named TeXnicCenter.exe, not TEXCNTR.EXE, as it appears in the tutorial.

  3. In the Viewer tab / View project's output section, you should select DDE command and the command should be "%bm.pdf" (as described in the tutorial) and the server should be SUMATRA. The topic should be control

  4. In the Viewer tab / Forward search section, you should select DDE command and the command should be [ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)] (as described in the tutorial) and the server should be SUMATRA. The topic should be control

  5. In the Viewer tab / Close document before running (La)TeX section you should select Do not close.

Graphical Description:

enter image description here

  • 1
    thanks a lot for note 1.2!!! I was searching this mistake for quite some time... – user33135 Jul 3 '13 at 8:56
  • 1
    @bjoern It is normal that when you do double click on a word in the Sumatra pdf you'll get directed to the paragraph in TeXnicCenter. Regarding the popup, it works perfectly with me (Windows Vista + TeXnicCenter 2.02 + Sumatra 2.3.2) – Mario S. E. Nov 8 '13 at 14:10
  • 1
    As an additional comment, always check the full path of Sumatra and of TeXnicCenter using the command prompt. I was confused by a Windows in Italian, where these programs appears under "Programmi" but are in reality under "Program Files" – Marco Lombardi Jan 15 '14 at 14:12
  • 1
    On the news site of WinEdt it is stated that 'PDF macros no longer use DDE for SumatraPDF. Using the command line switch -forward-search is faster and more reliable. Using a command line switch (if it exists) is always preferable (simple is better). Besides DDE does not (and will not) support Unicode!' Is this also true for TeXnicCenter? If so, an example how to set up the viewer settings using command line instead of DDE would be very much appreciated. – StackJack Aug 23 at 8:28
  • 1
    @StackJack Your wish is my command line :-) see CLI answer – KJO Oct 5 at 19:13

One further point to consider is the the language of the OS you're using. As I had to learn two different names in links (C:\Programme\... vs C:\Program Files\... which point to the same directory for a German Win 7 OS and are mapped by the OS automatically) are two different directories for the DDE. While the forward search was working as intended, the inverse search always fired up a new instance which lead to a project already in use clash.

After fixing this issue, everything works fine :)

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – texenthusiast Jul 8 '13 at 21:27
  • It does not work here. The paths are correct, so are the various brackets and quotes. When I double click in Sumatra, nothing happens. – Antonio Sesto Jul 15 '16 at 8:51

protected by Community Oct 30 '13 at 7:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.