2

I have a document that typesets fine with MikTeX on Windows. I have tried the same source on Ubuntu but I am getting an error:

! Package xwatermark Error: No page specifier for watermark: 
||{\fontspec {Georgia}Confidential.}||.

See the xwatermark package documentation for explanation.
Type  H <return>  for immediate help.

The watermark related bit is this:

\newwatermark[allpages,textcolor=gray!35,
  fontsize=1.5cm,textangle=60]{{\fontspec{Georgia}Confidential.}}

The xwatermark version appears to be 1.5.2a, February 2012.

Is this a known problem? Are there any workarounds?

UPDATE

This is Ubuntu Raring, in case it matters.

UPDATE 2

Reduced complete test case:

\documentclass[]{article}
\usepackage{xcolor}
\usepackage[printwatermark]{xwatermark}

\newwatermark[allpages,textcolor=gray!35,
  fontsize=1.5cm,textangle=60]{{Confidential.}}

\title{Title}
\author{Václav Zeman}
\date{2013-05-31}

\begin{document}
\maketitle
\end{document}

UPDATE 3

I have submitted a problem report to Ubuntu: https://bugs.launchpad.net/ubuntu/+source/tex-common/+bug/1186407

closed as too localized by Martin Schröder, Heiko Oberdiek, Werner, Stefan Kottwitz Jun 1 '13 at 21:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    The operating system doesn't matter at all, but add \listfiles to your document preamble and compare the version number log in each case see which packages differ – David Carlisle May 31 '13 at 19:57
  • @cmhughes: Updated. – wilx May 31 '13 at 20:00
  • I really don't know the reason for the weird error. You have certainly given the page specifier in [allpages,textcolor=gray!35, fontsize=1.5cm,textangle=60]. I don't use Ubuntu. Please try version 1.5.2d, available at CTAN/xwatermark. If the problem persists, Ubuntu users may help us. – Ahmed Musa May 31 '13 at 20:40
  • 1
    The updated MWE gives the error ! LaTeX Error: No \title given. unless you supply a title with \title{} That is the standard behaviour for article class \maketitle. If you supply a title it runs without error (texlive 2012) – David Carlisle May 31 '13 at 20:41
  • @AhmedMusa: I have tried the latest xwatermark version from CTAN. Unfortunately, it fails with other package version error. I am reluctant to modify more files in my otherwise working system. – wilx May 31 '13 at 20:54