2

I've been playing around with TeXLive 13 pretest on OSX, and I've been unable to tell luatex/luaotfload where to look for fonts.

I know that luaotfload will look in the standard font directories and that there is the variable $OSFONTDIR. What I try to do is make it look for the directory ~/Library/FontExplorerX where the Linotype FontExplorer stores its fonts.

When I try export OSFONTDIR=/Users/simi/FontExplorerX//:$OSFONTDIR, luaotfload-tool --update will scan the directory and make the fonts available. Unfortunately, this doesn't stick.

Where can I tell TL permanently where $OSFONTDIR is? I've read that putting the line OSFONTDIR= /Users/simi/FontExplorerX// in /usr/local/texlive/2013/texmf.cnf should do the trick, but this seems to have no effect. Neither luaotfload-tool nor kpsewhich seem to care about this setting.

4

One solution, if you are using the Bash shell, is to add

export OSFONTDIR=/Users/simi/FontExplorerX/

to your .bash_profile file.

  • I'm using bash, but I wonder whether this really sets the variable globally. For example, if I run lualatex with TeXShop and luaotfload-tool will start to rescan the font directories, will it use this setting? – Simifilm Jun 1 '13 at 12:04
  • @Simifilm According to linuxfromscratch.org/blfs/view/6.3/postlfs/profile.html, this setting may override the global settings. – user13907 Jun 1 '13 at 12:15
  • Is there conceptually any difference between .bash_profile and .profile? – Simifilm Jun 1 '13 at 12:17
  • 1
    @Simifilm Please, take a look at stackoverflow.com/questions/415403/… – user13907 Jun 1 '13 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.