I am pretty new both to LyX and to TeX.SX, and have no LaTeX background. I'm writing my master's thesis in LyX and have just changed the document style from book to book (Memoir). When I try to export to pdf (using pflatex), I get two error messages (1 and 2 below):


Argument of \reserved@a has an extra }.


Paragraph ended before \reserved@ was complete.

The explanations read:


{\Large{ Masteroppgave i lingvistikk}}} 
I've run across a `}' that doesn't seem to match anything. 
For example, `\def\a#1{...}' and
`\a}' would produce this error. If you simply proceed now, the `\par'
that I've just inserted will cause me to report a runaway argument
that might be the root of the problem. But if your `}' was spurious,
just type `2' and it will go away.


{\Large{ Masteroppgave i lingvistikk}}}
I suspect you've forgotten a `}', causing me to apply this
control sequence to too much text. How can we recover?
My plan is to forget the whole thing and hope for the best.`

Masteroppgave i lingvistikk is the last part of the my title, simply meaning 'Master thesis in linguistics'. I have separated my thesis title into three lines, using justified line breaks. All lines of the title are in title style, but they have different font sizes.

It seemed to work all right when I used the book document class, but after changing to Memoir something goes wrong.

EDIT: I've tried using ordinary vspace instead of justified line breaks, but then the pdf only shows one of the line breaks, the second one is somehow ignored.

EDIT: I'll try to make a minimal example (though I have never made one before):


\title{{\huge{<<Første linje av første tittel, andre linje av hovedtittel>>
{\Large{Første linje av undertittel, og andre linje}}\linebreak{}

  • this isn't going to solve the problem, but you don't need -- or want -- braces after \Large. that command, and others of its ilk (\small, \footnotesize, etc.) change the size of everything that follows until the end of the current group or localizing environment, or the end of the job. if it's not otherwise localized, bury it in a group with braces" {\Large ...}. – barbara beeton Jun 1 '13 at 16:33
  • so that readers of your question can more easily try to reproduce it, please provide a minimal working example (MWE), starting with \documentclass{...} and ending with \end{document}. – barbara beeton Jun 1 '13 at 16:36
  • I have tried to make a minimal example now. Please let me know if I didn't do it right, I have never done it before. – Fisla Jun 1 '13 at 18:36
  • 1
    yes, this is a very nice minimal example. @TorbjørnT has given an answer that will work with lyx. (i'm not a lyx user, so i can't do that.) he didn't, however, explain that the error you got was because \linebreak has unexpected side effects when used as part of the memoir \title command. line breaking can be done (error-free) with \` plus an optional extra dimension. after making those changes, you will still get a warning "No \author` given" but that can be ignored in your case. – barbara beeton Jun 1 '13 at 19:22

If I understand correctly what you're after, you can try the following in LyX to create your title:

  1. Add the title via the drop down menu.
  2. Write your main title. If you want a line break in the middle of it, hit Ctrl + Enter.
  3. Add some vertical space with Insert --> Formatting --> Vertical space. If you use Custom you can define the length yourself.
  4. Write the subtitle, again using Ctrl + Enter for a line break.
  5. Again, add some vertical space.
  6. Write "Masteroppgave".
  7. Select the subtitle and "Masteroppgave", right click the text, choose Text style --> Customized, set the size to Larger, and hit OK.

enter image description here

A working LaTeX example. I added some vertical space between the main title and the subtitle with \\[<length>]. As Barbara mentioned in the comments, \huge, \large etc. are switches, not commands that take an argument, so I removed the braces after those.

\title{\huge <<Første linje av første tittel, \\
andre linje av hovedtittel>> \\[2cm]
\Large Første linje av undertittel,\\ og andre linje
| improve this answer | |
  • Thanks a lot! It seems the vertical space is ignored if i don't put a line break in there together with it, though. I should add a vertical space from the taskbar AND use Ctrl+Enter to add a line break as well, right? – Fisla Jun 1 '13 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.