7

This question already has an answer here:

I've been trying to configure the margins on my file for 6x9 paper size, but ended up using the layout for a5 paper. For some reason I have not been able to set the point size since I have made those changes. I get an Unused Global Option error. Is there something I am missing or not seeing? As far as I can see, I simplified the codes by using a5 paper.

\documentclass[16pt]{book}%Compile with xelatex
\usepackage{polyglossia}
\usepackage[a5paper]{geometry}
\setdefaultlanguage{hebrew}
\newfontfamily\hebrewfont{Times New Roman}
\newlength\iiindent \setlength\iiindent{20pt} 
\newcommand\secindent{\parshape 3 0pt \linewidth 0pt\dimexpr\linewidth-\iiindent\relax 0pt \linewidth } 
\setlength\parindent{0pt}
\begin{document}
\leftskip=0cm plus 0.5fil \rightskip=0cm plus -0.5fil
\parfillskip=0cm plus -1fil
\sloppy
\everypar{\secindent}
הקדמת הרב המחבר

אמר המחבר החיבור הזה לא חברתיו ללמד לבני האדם את אשר לא ידעו אלא להזכירם את  הידוע להם כבר ומפורסם אצלם פירסום גדול. כי לא תמצא ברוב דברי אלא  דברים  שרוב  בני  האדם  יודעים אותם ולא מסתפקים בהם כלל. אלא שכפי רוב פרסומם וכנגד מה שאמתתם גלויה לכל. כך ההעלם מהם מצוי מאד וההשכחה רבה. ע"כ אין התועלת הנלקט מזה הספר יוצא מן הקריאה בו פעם אחת. כי כבר אפשר שלא ימצא הקורא בשכלו חידושים אחר קריאתו שלא היו בו לפני קריאתו אלא מעט. אבל התועלת יוצא מן החזרה עליו וההתמדה. כי יזכרו לו הדברים האלה הנשכחים מבני האדם בטבע. וישים אל לבו חובתו אשר הוא מתעלם ממנה. ותראה אם תתבונן בהוה ברוב העולם כי רוב אנשי השכל המהיר והפקחים החריפים ישימו רוב התבוננם והסתכלותם בדקות החכמות ועומק העיונים איש איש כפי נטיית שכלו וחשקו הטבעי. כי יש שיטרחו מאד במחקר הבריאה והטבע. ואחרים יתנו כל עיונם לתכונה ולהנדסה. ואחרים למלאכות. ואחרים יכנסו יותר אל הקדש דהיינו למוד התורה הקדושה. מהם בפלפולי ההלכות. מהם במדרשים. מהם בפסקי הדינים. אך מעטים יהיו מן המין הזה אשר יקבעו עיון ולמוד על עניני שלמות העבודה.

\end document

This is part of the output from the console:

LaTeX Warning: Unused global option(s):
    [16pt].


("C:\Documents and Settings\Compaq_Owner.HOME\My Documents\Documents\mesilat\me
silat.aux") ("C:\Program Files\MiKTeX 2.9\tex\latex\tipa\t3cmr.fd")
*geometry* detected driver: pdftex
[1]
Underfull \vbox (badness 10000) has occurred while \output is active [2]
Underfull \vbox (badness 10000) has occurred while \output is active [3]
[4]
Underfull \vbox (badness 10000) has occurred while \output is active [5]
[6] [7] etc. etc. etc.

marked as duplicate by lockstep, John Wickerson, Claudio Fiandrino, Stefan Kottwitz Jun 3 '13 at 11:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Thank you for your response. The guide I was using failed to mention this. I'll take a closer look. – Menachem Eliyahu Jun 3 '13 at 10:23
10

The normal LaTeX classes (e.g. book) only accept 10pt, 11pt or 12pt. You can't just put in any number there.

If you use one of the classes in the extsizes package (namely, extarticle, extreport, extbook, extletter or extproc) then you can use 8pt, 9pt, 10pt, 11pt, 12pt, 14pt, 17pt or 20pt. For instance:

\documentclass[17pt]{extbook}
1

If you are willing the change the document class you can use scrbook. It's a KOMA-script class. KOMA accept any font size by an option.

In your case it is:

\documentclass[fontsize=16pt]{scrbook}

Not the answer you're looking for? Browse other questions tagged or ask your own question.