1

I use the natbib package, and my bibliography style is acm (small caps). I would like to have 'year' appearing right after the author name, but I get this error message:

! Package natbib Error: Bibliography not compatible with author-year citations.

I have checked that all the entries in my .bib file have a year. In addition, I made sure my .bib file is encoded in UTF-8, supported by natbib. Any suggestions?

\documentclass[12pt,a4paper]{article}
\usepackage[english]{babel}
\usepackage[numbers,authoryear]{natbib}
\begin{document}
blablabla
\nocite{*}
\bibliographystyle{acm}
\bibliography{FinalVersion}
\end{document}
4
  • 2
    I don't know natbib at all, but aren't numbers and authoryear contradictory options?
    – henrique
    Commented Jun 3, 2013 at 21:16
  • Welcome to TeX.SX!
    – mafp
    Commented Jun 3, 2013 at 21:31
  • yes probably. If I only use authoryear it doesn't work.
    – chicoutimy
    Commented Jun 3, 2013 at 21:45
  • Please try with just \usepackage{natbib} and see what happens. Commented Jun 3, 2013 at 22:09

1 Answer 1

2

The acm bibliography style is not compatible with natbib. You can make it work with

\usepackage[numbers]{natib}

but this still does not give you access to natbib's features. Hence, you should choose a different bibliography style. If you like numerical citations with the authors in small caps in the bibliography, I recommend acmtrans with natbib's numbers option.

\documentclass[12pt,a4paper]{article}
\usepackage[english]{babel}
\usepackage[numbers]{natbib}
\begin{document}
blablabla
\nocite{*}
\bibliographystyle{acmtrans}
\bibliography{FinalVersion}
\end{document}
12
  • Indeed I can make acm work with only \usepackage[numbers]{natbib}. However, if I try the same with acmtrans, I get the following error message: I couldn't open style file acmtrans.bst
    – chicoutimy
    Commented Jun 4, 2013 at 9:17
  • @chicoutimy You need to install the acmtrans package.
    – mafp
    Commented Jun 4, 2013 at 9:23
  • Excuse me but do you know in which folder I should install this package? I use a mac
    – chicoutimy
    Commented Jun 4, 2013 at 9:46
  • I think I managed to install the acmtrans package. However, this doesn't solve my problem. I would like year to appear after author but the same message Bibliography not compatible with author-year citations appears. Can someone help?
    – chicoutimy
    Commented Jun 4, 2013 at 10:01
  • @chicoutimy installation depends on your TeX distribution. For example, if you use TeXLive you should have tlmgr for the job.
    – mafp
    Commented Jun 4, 2013 at 10:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .