Is there any way to make Texmaker automatically display my LuaLaTeX generated PDF in his internal PDF viewer ? It works if I use an external PDF viewer:

lualatex --interaction=nonstopmode %|"C:\Program Files (x86)\Foxit Software\Foxit Reader/Foxit Reader.exe" %.pdf

But then I have to manually close the PDF to run LuaLaTeX again. With pdfLaTeX this works automatically, but LuaLaTeX can't seem to find the PDF.

(I'm using Texmaker 4.0.2, MikTeX 2.9 and Windows 7)

1 Answer 1


1) Just use the "wizard" button at the end of the line for the "user quick build command".

2) Add "pdflatex" and "View Pdf" -> "Ok"

3) Then replace, in the command line, pdflatex by lualatex

4) Be sure that the "Build-in viewer" option is checked and select the "user" option for the "quick build command".


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .