1

I'm new to making tables and I'm having a problem with them taking up way too much of my page.

\begin{table}[ht]
  \centering
  \caption{Table F8: Fertility Rates by Generation and Marriage Type}
    \begin{tabular}{lrrrrrr}
    \hline \hline
& \multicolumn{3}{c}{First Generation} & \multicolumn{3}{c}{Second Generation} \\
    \hline
& \multicolumn{1}{c}{Single} & \multicolumn{1}{c}{Endogamous} & \multicolumn{1}{c}{Exogamous} & \multicolumn{1}{c}{Single} & \multicolumn{1}{c}{Endogamous} & \multicolumn{1}{c}{Exogamous} \\
15-19 & 0.13  & 0.45  & 0.26  & 0.12  & 0.46  & 0.58 \\
20-24 & 0.58  & 1.27  & 0.75  & 0.42  & 0.90  & 1.14 \\
25-29 & 0.71  & 1.11  & 0.65  & 0.52  & 0.85  & 1.08 \\
30-34 & 0.71  & 1.02  & 0.60  & 0.53  & 0.52  & 0.66 \\
35-39 & 0.50  & 0.46  & 0.27  & 0.15  & 0.34  & 0.43 \\
40-44 & 0.13  & 0.13  & 0.08  & 0.03  & 0.21  & 0.27 \\
Total Fertility Rate & 2.76  & 4.43  & 2.61  & 1.78  & 3.29  & 4.16 \\
\hline
    \textit{Source: National Survey of Family Growth, 2006-2010} &  \\
    \hline
    \end{tabular}
 % \label{tab:addlabel}
\end{table}

From this, I'm getting a massive first column (takes up almost the entire page) and I can't see the rest of my columns.

How do I get the right spacing?

  • I clearly need help, because I don't even know how to format my question right!!! – CharlieTango Jun 5 '13 at 16:39
  • 2
    welcome to tex.sx, you can mark code sections by highlighting them and using the {} button in the editor. Replace \textit{Source: National Survey of Family Growth, 2006-2010} & by \multicolumn{7}{l}{\textit{Source: National Survey of Family Growth, 2006-2010}} – David Carlisle Jun 5 '13 at 16:42
2

Remarks for the following example:

  • The last line for the source specification is missing \multicolumn.
  • The en dash -- instead of the hyphen - is used for number ranges, e.g. 15--19, 2006--2010.
  • I have added package booktabs to avoid the double \hline at the begin of the table.
  • Additional hyphenations are added to avoid an overfull \hbox.
  • Package caption fixes the reversed lengths \abovecaptionskip and \belowcaptionskip for captions above the table.
  • Table 1: Table F8: does not look too good.

Example file:

\documentclass{article}
\usepackage{booktabs}
\usepackage{caption}
\begin{document}
\begin{table}[ht]
  \centering
  \caption{Table F8: Fertility Rates by Generation and Marriage Type}
  \label{tab:addlabel}
  \begin{tabular}{lrrrrrr}
  \toprule
  & \multicolumn{3}{c}{First Generation}
  & \multicolumn{3}{c}{Second Generation} \\
  \midrule
  & \multicolumn{1}{c}{Single} & \multicolumn{1}{c}{Endo-}
  & \multicolumn{1}{c}{Exo-} & \multicolumn{1}{c}{Single}
  & \multicolumn{1}{c}{Endo-} & \multicolumn{1}{c}{Exo-} \\
  & & \multicolumn{1}{c}{gamous} & \multicolumn{1}{c}{gamous} &
  & \multicolumn{1}{c}{gamous} & \multicolumn{1}{c}{gamous} \\
15--19 & 0.13  & 0.45  & 0.26  & 0.12  & 0.46  & 0.58 \\
20--24 & 0.58  & 1.27  & 0.75  & 0.42  & 0.90  & 1.14 \\
25--29 & 0.71  & 1.11  & 0.65  & 0.52  & 0.85  & 1.08 \\
30--34 & 0.71  & 1.02  & 0.60  & 0.53  & 0.52  & 0.66 \\
35--39 & 0.50  & 0.46  & 0.27  & 0.15  & 0.34  & 0.43 \\
40--44 & 0.13  & 0.13  & 0.08  & 0.03  & 0.21  & 0.27 \\
Total Ferti-\\
lity Rate & 2.76  & 4.43  & 2.61  & 1.78  & 3.29  & 4.16 \\
  \midrule
  \multicolumn{7}{l}{%
    \textit{Source: National Survey of Family Growth, 2006--2010}}  \\
  \bottomrule
  \end{tabular}
\end{table}
\end{document}

Result

  • Thanks! I've got the Table F8 in there so I can identify my tables with my text. I'm going to back in at the end and get rid of those. I added in booktabs too, thanks. Also the dash tip! I apologize, I am a true novice at this. It's a last minute requirement for my dissertation. – CharlieTango Jun 5 '13 at 17:12
2

My opinion would be that you were doing a \multicolumn in the last line, i.e.:

\begin{table}[ht]
  \centering
  \caption{Table F8: Fertility Rates by Generation and Marriage Type}
    \begin{tabular}{lrrrrrr}
    \hline \hline
& \multicolumn{3}{c}{First Generation} & \multicolumn{3}{c}{Second Generation} \\
    \hline
& \multicolumn{1}{c}{Single} & \multicolumn{1}{c}{Endogamous} & \multicolumn{1}{c}{Exogamous} & \multicolumn{1}{c}{Single} & \multicolumn{1}{c}{Endogamous} & \multicolumn{1}{c}{Exogamous} \\
15-19 & 0.13  & 0.45  & 0.26  & 0.12  & 0.46  & 0.58 \\
20-24 & 0.58  & 1.27  & 0.75  & 0.42  & 0.90  & 1.14 \\
25-29 & 0.71  & 1.11  & 0.65  & 0.52  & 0.85  & 1.08 \\
30-34 & 0.71  & 1.02  & 0.60  & 0.53  & 0.52  & 0.66 \\
35-39 & 0.50  & 0.46  & 0.27  & 0.15  & 0.34  & 0.43 \\
40-44 & 0.13  & 0.13  & 0.08  & 0.03  & 0.21  & 0.27 \\
Total Fertility Rate & 2.76  & 4.43  & 2.61  & 1.78  & 3.29  & 4.16 \\
\hline
  \multicolumn{7}{l}{\textit{Source: National Survey of Family Growth, 2006-2010}}   \\ % THIS LINE!!!
    \hline
    \end{tabular}
 % \label{tab:addlabel}
\end{table}

and you see this: enter image description here

  • Thank you! Now I have a big ugly vertical line at the far right end of my table. Ideas about that? Wow, this is amazing. Normally I spend hours trying to figure out these problems on my own. – CharlieTango Jun 5 '13 at 16:53
  • @CharlieTango are you using the draft class option? If so, black vertical stripes will be produced in your document to signal overfull \hboxes. – Gonzalo Medina Jun 5 '13 at 17:00
  • @Gonzalo Medina: Yes, I went to my control file (I'm working off a dissertation template) and it does have the draft option. Can I just turn that off? What does it do? ETA: I got brave and tried it! Angry black line is gone! Thank you! Thank you everyone for your patience. In their infinite wisdom, our graduate school has suddenly required our dissertations to be put into LaTeX. 3 weeks before I have to submit it. – CharlieTango Jun 5 '13 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.