9

I have a document containing some short paragraphs which would fit on a single line using normal spacing. When typesetting those paragraphs LaTex apparently tries hard to stretch those lines (the words) far enough to make it a two-line paragraph. That produces some very ugly paragraphs. LaTex even hyphenates the last word of the paragraph to get only the shortest possible part of it on the second line.

I tried adjusting the word stretching by lowering the setting for \fontdimen3\font to 0.2pt but this does not feel right.

Is it possible to tell LaTeX not to stretch paragraphs on at least 2 lines?

Edit:

I found the cause deep down in our templates:

\tolerance 1414
\emergencystretch 1.5em

Here's a minimal working example:

\documentclass[parskip=half*]{scrartcl}
\tolerance 1414
\emergencystretch 1.5em
\begin{document}
   This is a sentence that would usually fit on one line with normal spacing.
\end{document}

Removing one of both lines fixes the spacing of one line paragraphs. I am not yet familiar with what those commands do exactly, but I assume they had been added because some of the generated code produced overfull text lines.

Still, I don't understand why - with these settings - LaTeX tries to produce an extra line in the paragraph. From what I understand, \tolerance and \emergencystretch are supposed to jump in when formatting within the default rules is not possible. Where am I wrong?

Edit2

The parskip=half* setting for the srcartcl document class appears to play a role in this game, also.

4
  • 4
    Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. (LaTeX certainly does not 'try to make paragraphs at least two lines'.)
    – Joseph Wright
    Commented Jun 6, 2013 at 11:15
  • If you have a lots of short paragraphs together, perhaps you could put them into one of the list environments? Alternatively maybe setting \raggedright for some portion of your document. Can you provide an example?
    – Thruston
    Commented Jun 6, 2013 at 11:25
  • 1
    Thanks for your comments so far. @Joseph: Good to know, LaTeX does not try to make paragraphs at least two lines, so maybe its something in my setup. I will try to provide a MWE but that's not so easy right now, because I'm within a system generating TeX code from a model. But I'll try to strip it down.
    – jkow
    Commented Jun 6, 2013 at 11:50
  • @Thruston: Thanks also for proposing the list environment, but I am dealing with LaTeX code generated from a model and the generator cannot decide wether a short paragraph should be part of a list. Sometimes it's just a sentence that is meant to stand alone. Also I cannot do any manual tweaking of paragraphs in the LaTeX code -- I have to find a general solution.
    – jkow
    Commented Jun 6, 2013 at 12:45

1 Answer 1

4

use parskip=half and not half*:

\documentclass[11pt, a4paper, 
  parskip=half,% <=====
  bibliography=totoc, 
  final,  
  numbers=noenddot]{scrartcl}

Read the documentation of KOMA-Script for the difference.

2
  • Might be worth commenting that in the .log with setting parskip=half* you get a warning about an overfull box, which is why TeX is fiddling with the paragraph at all.
    – Joseph Wright
    Commented Jun 6, 2013 at 15:04
  • Thanks Herbert and Joseph for your fast response - that was the solution!
    – jkow
    Commented Jun 6, 2013 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .