1

I can't get moderncv to work. I get the error:

! LaTex Error: File 'tweaklist.sty' not found.

What I've done so far is manually install moderncv in my texmf tree (/usr/local/texlive/2008/texmf-dist/tex/latex/moderncv)

tweaklist.sty is in this directory, but when I run

\documentclass{moderncv}
\begin{document}
;lakdjfl
\end{document}

it gives the aforementioned error

  • Did u update the name database etc.? I'm not sure how to do this for texlive but there should be an option somewhere.You always have to do this after installing a new package. – Mythio Jun 6 '13 at 13:52
  • 2
    Why do you work with such an outdated version of TeX Live? I really recommend an update of your TeX distribution. Perhaps the newest version TeX Live 2013 ;-) tug.org/texlive/pretest.html – Marco Daniel Jun 6 '13 at 13:53
  • Try kpsewhich moderncv.cls and check whether TeX does indeed use the version you installed. Then try kpsewhich tweaklist.sty, and if any don't give the desired result, run texhash. – Xavier Jun 6 '13 at 16:42
  • I would ditch tweaklist and use enumitem instead – cmhughes Jun 6 '13 at 19:02
  • @MarcoDaniel I installed the 2013 version of tex live. it is now in the same folder as the 2008 version. when I run my code in texshop it still uses the 2008 version. how can I change the path that is being used? – jelle Jun 27 '13 at 12:28
2

You don't give all the information needed to fully answer your question, but since you are using a Mac, there are two basics to pay attention to:

  1. Install TeXLive using the MacTeX installer. This will save you no end of headaches in the future, and furthermore, most of us who use Macs will assume you have this setup.

  2. Check your TeXShop preferences. Given that you were previously running TL 2008, it's possible that TeXShop has a direct path to the binaries in the preferences. With a recent version of TeXShop you should just be able to choose the "Set Default Values" in the Engine preference panel to reset all of the relevant paths etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.