11

The hyphenation in my bibliography is off somehow, I can't figure out why. Look:

\documentclass{scrreprt}  
\usepackage[style=alphabetic,hyperref=true]{biblatex} 
\bibliography{\jobname.bib} 
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@book{Fowler:2006,
    Address = {Boston},
    Author = {Fowler, Martin},
    Publisher = {Addison-Wesley},
    Title = {Patterns of Enterprise Application Architecture},
    Year = {2006}}

@book{Rotem-Gal-Oz:2012,
    Address = {Shelter Island, NY},
    Author = {{Rotem-Gal-Oz}, Arnon},
    Publisher = {Manning Publications Co.},
    Title = {SOA Patterns},
    Year = {2012}}
\end{filecontents}

\begin{document}
\nocite{Fowler:2006} \nocite{Rotem-Gal-Oz:2012}
\printbibliography
\end{document}

Now, when you compile that you can see that the "Addison-" of "Addison-Wesley" is too long. (I put in another Bib-Entry for your reference). Addison is to long.

I could fix this with Add\-ison but that's just weird. Also, I have more than one occurrence in my file and I dislike having to check for this error again and again.

So, what do I do now?

8
  • 6
    LaTeX hyphenates words with hyphen only at the hyphen. You could use the command \hyphen offered by biblatex instead of the -. Jun 7, 2013 at 11:50
  • In fact, I see the same issue with non-hyphenated words as well. Example: @book{Vossen:1996, Address = {Bonn}, Author = {Vossen, Gottfried AND Becker, J{\"o}rg.}, Isbn = {978-3826601248}, Keywords = {Gesch{\"a}ftsprozesse, Definitionen}, Publisher = In\-ter\-na\-tion\-al Thomson Publ., Title = {Gesch{\"a}ftsproze{\ss}modellierung und Work\-flow-Management. - Modelle, Methoden, Werkzeuge.}, Year = {1996}} The "Thomson" is not hyphenated correctly and too long. see: Picture of Thomson too long
    – albifant
    Jun 7, 2013 at 12:18
  • 3
    The word Thomson is hyphenated correctly in the picture you've linked in the comment. You could try issuing the command \sloppy right before \printbibliography to let TeX find a different way to break lines. Alternatively, consider loading the package ragged2e and issuing the command \RaggedRight before \printbibliography.
    – Mico
    Jun 7, 2013 at 12:27
  • @Mico \sloppy worked perfectly fine. I'll go with that, thank you. You might post that as an answer I can "accept".
    – albifant
    Jun 7, 2013 at 12:58
  • 1

1 Answer 1

14

When dealing with material that's difficult to hyphenate, it can help at times -- but it's not guaranteed to work under all circumstances -- to provide the directive \sloppy. The \sloppy instruction lets TeX find line breaks by widening the amount of inter-word whitespace far more than is (normally) considered to be tolerable. However, do be sure to exhaust other possibilities before resorting to using \sloppy -- the results you may get with this method may look, well, sloppy!

6
  • 3
    To be honest, I think this is a perfect solution for bibliographies. It might not help all the time but it did for me without exceptions.
    – phx
    Nov 1, 2016 at 19:44
  • 3
    How do you cancel the effects of \sloppy when more sections follow the bibliography?
    – m000
    Aug 26, 2020 at 17:14
  • 2
    @m000 - \fussy.
    – Mico
    Aug 26, 2020 at 17:43
  • 1
    how can I check whether \sloppy is still active? Nov 29, 2021 at 14:15
  • 1
    I guess I care more about the typesetting result than about programmatically asking for the status. But yeah, a conditional would tell me, whether \sloppy has accidentally been left on. I guess it manipulates some internal settings which could be queried for. Dec 1, 2021 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.