I'm having a little trouble with a submission to arXiv and I don't know if people here can help diagnose it. Simply put, the arXiv tex compiler is screwing up the bibliography for reasons I don't understand.

In the paper.bbl file for paper.tex, you have entries such as:

\bibitem[\protect\citename{Mitchell and Lapata}2008]{mitchell2008vector}
J.~Mitchell and M.~Lapata.
\newblock 2008.
\newblock {Vector-based models of semantic composition}. 
\newblock In {\em Proceedings of ACL}, volume~8.

When I compile the paper with pdflatex, I obtain bibliography items such as:

Citations in local version

However, when I upload the tex to arxiv (along with all the accompanying files, and with the macro \pdfoutput=1 at the top of the tex document) I get the following output for the same bibliography item.

Citations on arXiv

As you can see, it's adding the information from the bibitem option into the references themselves. Does anyone have any idea how I can get arXiv's pdflatex to stop doing this? Am I doing something wrong on my end, or should I contact arXiv and tell them something is broken on their end?

If it helps. here's the tex log generated by arxiv: http://pastebin.com/uCFBzuiH

Thanks in advance for any help you can provide!

Edit: Answer to this problem provided by Lev Bishop in the comments below. Just make a file 00README.XXX with the line nohypertex in it.

  • The arxiv output you show is the output I would expect from the bbl input that you posted. \bibitem is like \item and its optional argument is usually printed. Jun 8, 2013 at 0:21
  • @DavidCarlisle: According to math.uiuc.edu/~hildebr/tex/bibliographies.html the [args] allow the specification of how the citations are labeled in text. Is there not a way to surpress their appearance in the bibliography? Why are they not appearing when I run pdflatex locally? Jun 8, 2013 at 0:32
  • To answer my own question, the document is using the acl2013 style (acl2013.org/site/Latex/acl2013.sty) which has a section stating that it suppresses bibliography labels. The question is now, why is arXiv ignoring this part of the style file? Jun 8, 2013 at 0:39
  • 4
    Just a guess: you could make a file 00README.XXX with the line nohypertex in it. See here
    – Lev Bishop
    Jun 8, 2013 at 1:09
  • 1
    @LevBishop: That worked! I have no idea why, but it did. Thanks :) Is there an explanation? Jun 8, 2013 at 1:13

1 Answer 1


Make a file 00README.XXX with the line nohypertex in it. The uses of the 00README.XXX file are described in the arXiv help.

By default arXiv processes files with HyperTeX (something like automatically adding \usepackage[implicit]{hyperref}), which can occasionally conflict with certain classes and styles, as appears to be the case here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.