5

I felt this should be a follow-up question. If not, please remove it. The original question was Workflow for managing references?. I am using TeXStudio 2.5.2 in Windows 7, biber and biblatex for the bibliography. I have followed the excellent guide that @doctorate has provided, but I have found two minor flaws.

When I copy an article from Zotero directly to a .tex document, or when I export to a .bib file, the names of the authors are not correct. For example names like: Gregoire and Chate have an accent on the e's and while they should be imported in the bibliography like this:

Gr\'{e}goire and Chat\'{e}

They are in fact copied with the accents, so when I compile my document I get random symbols on these names. Is there a way to correct this, or use a different tool? For now, these occurrences are not many, so I manually corrected everything and it works beautifully! :)

The second part is that the field urldate actually imports a field: "Visited on XX/XX/XXXX" that was not there in the MWE. Again, I deleted the field in the .bib file and it works, I'm just wandering why it didn't show on that setup and it does in mine.

As I am finishing my first ever LaTeX document and I am new to Tex.SE this is probably a final question for the meta. Are we allowed to use code other users provide as examples?

Any suggestions are really welcome.

6

The issue of names with accent letter (or other non ASCII character) can be solved using

\usepackage[utf8]{inputenc}

For the issue about urldate you can suppress it from the output using

\AtEveryBibitem{\clearfield{urlyear}}

For the meta question: the contribution to Tex.se are under cc-wiki attribution license, so they can be used.

4

FWIW - while using utf-8 as per above is surely preferably where your bibtex implementation allows (as biber/bilatex do), you can get Zotero to escape accented characters in bibtex: In the Zotero Preferences, under "Export" make sure the box "Display Character Set on Export" is checked. Then, when exporting to Bibtex, select a non-utf-8 charset - typically ISO-8859 - and Zotero will escape accented letters and many (though not all) other utf-8 characters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.