I use TeXworks to write my documents. The spell checker tool works nice, but I'd like to add some words to the dictionary, but I can't find a function for that.

So how can I do that?

  • 2
    You may want to use a spell checker on your title :-) Commented Feb 23, 2011 at 16:05
  • 1
    @Hendrik Vogt: You are my spell checker ;) Commented Feb 23, 2011 at 16:10

7 Answers 7


TeXworks uses a spell checker called Hunspell, an engine which is also used e.g. by OpenOffice:

Each dictionary consists of two files with the extensions .dic and .aff. Where these are located depends on your TeXworks installation, on my system (TeX Live 2010, Windows), they are in the directory

C:\Users\<user name>\.texlive2010\texmf-config\texworks\dictionaries

Adding words to the dictionary is quite simple: As the .dic file is a plain word list, you can just add new lines with your own words. If you want the system to recognize different word forms, too, you have to deal with the .aff file - see this explanation for more details. However, simply changing the word list should be enough in most cases.

  • 6
    For MikTeX and Windows 7, the directory is C:\Users\<user name>\AppData\Local\MiKTeX\<MiKTeX version>\TeXworks\<TeXworks version>\dictionaries
    – Chang
    Commented Oct 6, 2011 at 1:09
  • 1
    See also tex.stackexchange.com/questions/33139/…
    – Stephen
    Commented Feb 15, 2012 at 19:13
  • 6
    This solution is not so convenient. TeXworks should add this feature to their good editor. Commented Jan 29, 2013 at 9:13
  • 4
    For MikTeX and Windows 7, actually, the directory is C:\Program Files (x86)\MiKTeX 2.9\hunspell\dicts
    – Echeban
    Commented Feb 27, 2013 at 10:49
  • 4
    As stated in TeXworks wiki > Obtaining dictionaries Windows To find the correct folder, use "Help -> Settings and Resources...", navigate to the "Resources" folder given there, and finally put the spelling dictionaries in the dictionaries folder (if it doesn't exist, create it).
    – escalator
    Commented Dec 11, 2013 at 9:52

I managed to install the dictionary PT_EU as follows:

I opened the TeX works went to Help -> Settings and Features and clicked C:/Users/Abilio/AppData/Local/MiKTeX/2.9/TeXworks/0.4

After downloading the dictionary did PT_EU http://extensions.services.openoffice.org/en/dictionaries site, downloading a file. Otx. then open this file with 7-zip, and copied the folder "Dictionaries" folder to the 0.4.

Then I copied the entire folder TeXworks (C:/Users/Abilio/AppData/Local/MiKTeX/2.9/TeXworks/), to the following path C:/Users/ Abilio / AppData / Local /. Then I reopen the TeXworks, and the dictionary was already there and it worked.

I have windows Vista 32-bit.

  • Welcome to TeX.sx! Diabonas' answer already points to the need of installing the dictionary files in the first directory you mentioned. Why would you need to move the entire TeXworks folder? Doesn't it break the MikTeX tree (for updates and such)?
    – henrique
    Commented Oct 26, 2012 at 1:43

In a MiKTeX 2.9 / Windows 8 context, the file to modify turned out to be

/Users/(username)/AppData/Local/Programs/MiKTeX 2.9/hunspell/dicts/en_US.dic

There was no problem editing it with a Unix-style editor within Cygwin. The file has a word count at the beginning, but it did not seem necessary to increment the word count when adding new words. I presume the word count is used for storage allocation when the file is loaded. I added new words in alphabetical order.

The remark above about making a backup is right on!


[Windows 7 Ultimate x86, TeXworks Version 0.4.5 r1280 (MiKTeX 2.9)]

I couldn't get my dictionary to be recognised in the c:\Users\<username> folder structure. So, instead, I copied the .dic, .aff files directly into the hunspell\dicts sub-folder of my MiKTeX install (I have it in c:\Program Files\LaTeX) and that worked.

I then followed diabonas' advice about adding my own words to the .dic file, but they weren't immediately recognised by TeXworks as valid words. I tried opening TeXworks a few times to see if it would finally recognise my changes, but to no avail. The following worked for me in the end:
1) I deleted the .dic, .aff I had copied in to the install folder (as explained above),
2) I opened TeXworks to confirm my dictionary was no longer available.
3) I added the new words to the original .dic file I downloaded (in the download folder I chose),
4) I then copied the edited files back in the hunspell/dicts folder as stated above.
5) I went back to TeXworks, and it was all good now.

I can't explain why making the edits directly in the hunspell\dicts folder would not work. Perhaps something to do with caching or they get compiled. I did not try to reboot my OS since I thought that was not necessary.



I had a similar issue, but with OS X Yosemite. I accidentally caused the built-in OSX spelling dictionary (which is what many LaTeX editors use) to incorrectly learn a misspelled word. By directly editing the text file at ~/Library/Spelling/LocalDictionary you can customize the editor to ignore common LaTeX syntax and to add custom words to ignore.


I am using TeXworks 0.6 at Windows 10.

It seems that TeXworks looks for dictionaries in two places,



/Users/<username>/AppData/Local/Programs/MiKTeX 2.9/hunspell/dicts/

I have added the same .dic and .aff files in both locations and I get two options for each language double entries for dictionaries.

The number in the first line of the .dic files is the word count. If you add words and do not update the word count, my guess is that the last few words (after the word count) will be ignored. (I haven't tested it though). If you remove the number of words, all the words will be ignored (the dictionary will appear as an option though).


In Arch Linux is very simple:

After installing hunspell:

sudo pacman -S hunspell

Installing English language spellchecker:

sudo pacman -S hunspell-en_US 

and for the Spanish language spellchecker:

sudo pacman -S hunspell-es_es

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .