I am using tikz for many pictures in my thesis, but I am not really clear on how to scale the pictures to fit my needs... I generally use "\node"s which I connect with line segments. I draw and fill the nodes to make them small black circles. I use a different node style to create nodes without draw/fill to place text in them.

Unfortunately most of the coordinates for nodes are generated by another program. As a consequence, the coordinates are all in between 0 and 1. Since that is much too small for me, I scale the pictures up by passing scale=... to the tikzpicture. Unfortunately this also scales the size of the nodes and the fontsize which is equally annoying. I would like to scale the coordinates of all my nodes without scaling either the node or the font size. Is that possible using tikz?

closed as unclear what you're asking by percusse, Mensch, Torbjørn T., dustin, Joseph Wright Aug 4 '13 at 16:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    By default, TikZ doesn't scale the font size (that's one of the great things of generating diagrams directly in LaTeX). It seems the program that generates your code changes this, though. You can try putting \tikzset{every node/.append style={transform shape=false}} to your document to prevent the scaling from happening. If that doesn't work, please edit your question to include an example tikzpicture that demonstrates the issue. – Jake Jun 13 '13 at 14:45
  • Same idea as the previous comment. Specify in your \begin{tikzpicture} options the following where X and Y can be whatever you want so that you'll get the desired effect:scale=X,every node/.style={scale=Y} – Ludovic C. Jun 13 '13 at 14:50
  • I just realized a part of my problem: Since the filled \nodes were always much too large for my purposes, I scaled everything down first... But then I had to scale the nodes containing text up again... – hfhc2 Jun 13 '13 at 15:15
  • 1
    @hfhc2: It's hard to tell without an example, but I think you're going about the resizing problem with your nodes the wrong way. Instead of scaling them down, try putting inner sep=0pt, minimum size=<desired size> in the nodes that are too large. – Jake Jun 13 '13 at 17:03

Browse other questions tagged or ask your own question.