1

I am using Ubuntu 11.10 and installed texlive 2012. I was using TEXMAKER and it was nice to use.

Meanwhile I want to try to use Lyx. I installed version 2.00 of Lyx. When I compile simple document in Lyx I get nice output. But when I check the version of texlive, it says 2009/Debian.

I wonder if I can get some help on tuning Lyx so that it use version 2012 rather than 2009 during compilation.

Many thanks in advance.

closed as too localized by Martin Schröder, Heiko Oberdiek, Przemysław Scherwentke, Werner, Mensch Jun 16 '13 at 2:54

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • There should be settings by which you can declare the binaries used. – Sean Allred Jun 14 '13 at 11:48
  • Ubuntu 11.10 is unsupported. Upgrade. – Martin Schröder Jun 15 '13 at 22:20
1

LyX just runs "pdflatex yourfile.tex" so this is not a LyX issue. This is a path issue. To use TeX Live 2012 you need the binaries to be found before the 2009 binaries. So export your PATH (e.g. in your /etc/profile) so that this is true. To see what your path currently is, run echo $PATH. Also which and type will be useful for you. e.g. which pdflatex.

Not the answer you're looking for? Browse other questions tagged or ask your own question.