2

I have to write a paper for UNI, as a requirement I have to respect the template and the rules set by the supervisors for writing the paper in LaTeX.

There is a requirement stating: After the abstract add your local table of contents with the commands

\bigskip\par\hrule\smallskip\par\setcounter{minitocdepth}{2} \dominitoc.

Since my experience with LaTeX is very slim, I fail to understand what is happening there, and how a table of content can be created with those lines.

Would you please explain what's happening there in a simple fashion, understandable for someone inexperienced.

additional info from the rules:

Your header must look as follows:

\documentclass{svmult}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{makeidx}
\usepackage{graphicx}
\usepackage{multicol}
\usepackage[bottom]{footmisc}
\usepackage{amsmath, amssymb, amsfonts, amscd}
\usepackage{algpseudocode}
\usepackage{algorithm}
\usepackage{listings}
\usepackage{verbatim}
\makeindex

SOLUTION:

OK seemed to work like this:

Didn't do much, just had to refresh the FNDB (filename database) and then it worked... Well I use MikTeX on windows, I think the equivalent of refresh FNDB in Linux is $ texhash

To explain the workflow.

  1. Just pasted the line \bigskip\par\hrule\smallskip\par\setcounter{minitocdepth}{2} \dominitoc

  2. then added \usepackage{minitoc} to the header, so it gets installed to the Miktex, then had to remove it because it gave some error.

  3. after removing that line and refreshing FNDB everything worked fine. There is no need to write \tableofcontents or something, the table of content is generated automatically

Thanks for the patience!

Peace!

4
  • Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format.
    – Corentin
    Jun 17, 2013 at 17:23
  • I don't think this show a table of content. it merely initialises a minitoc (per-chapter toc).
    – long tom
    Jun 17, 2013 at 17:46
  • Probably they require to write the line you mentioned just after the abstract and then place the command \tableofcontents Jun 17, 2013 at 18:34
  • 1
    Great you found a solution. Please selfanswer your question (this is welcome here) and delete your solution part in your question. It is just the way we do it here ... Your point 2 must not be the working one. It depends on your configuration. So better say one need to use package minitoc. If it is not installed (basic version) you can install it with the paket manager of MiKTeX (or your way ...).
    – Mensch
    Jun 17, 2013 at 19:45

1 Answer 1

1

The OP forgot to load the package minitoc After adding it works well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .