I use biblatex with biber and as style alphabetic

\usepackage[backend = biber, style=alphabetic ,maxnames=4,minnames=3,maxbibnames=99]%

At the moment, I get for all bibliography entries with more than 4 authors something like [McW+07] (first three letters of the family name of the first author) but I would like to get [MBC+07]. (M, B and C are the initials of the first three authors)

Is there a way to change my LaTeX code to solve my problem?

  • We really need a complete minimal example for this. Biber's label generation is much more complex and configurable than bibtex and it's likely just a settings issue but it's hard to guess without a MWE. – PLK Jun 18 '13 at 19:31

This is just a settings issue. If you look at the ieee-alphabetic.cbx, you'll see that all it does is set some options and then load alphabetic:

      maxalphanames = 4,
      maxcitenames  = 3,
      minalphanames = 3,
      minnames      = 1

Label generation is done using maxalphanames/minalphanames and maxnames/minnames does not change this (because these are only enabled if the labelalpha option is true). So, you just need to set maxalphanames=4 and minalphanames=3 and you can use alphabetic as normal. See these options in the PDF doc.

You also might want to look at \DeclareLabelalphaTemplate as you can customise the format of labels quite a lot. As you've found out, this label generation interacts with the maxalphanames/minalphanames settings.

  • So, there is no bug in biber? Is it the normal behaviour? – karlkoeller Jun 18 '13 at 20:32
  • There's no bug with biber, this is expected behaviour. – PLK Jun 19 '13 at 6:31

Ok, that's my work around:

\usepackage[backend = biber,citestyle=ieee-alphabetic, bibstyle=alphabetic ,maxnames=4,minnames=3,maxbibnames=99]{biblatex}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.