I'm writing my MSc thesis using LaTeX in Persian. When I use the XePersian package all the references including the number of sections, figures, equations, references disappear. Only the numbers of chapters are shown. I don't know what to do. When I remove the command \usepackage{xepersian} all the numbers come back but I cannot write in Persian.

I would be thankful if anyone can help me.

  • This is not normal behaviour of XePersian. Perhaps you did something wrong. Provide an MWE (minimal working example) that illustrates your problem. – Hasan Zakeri Jun 18 '13 at 18:05
  • @HasanZakeri: I even tried a simple example in the XePersian manual and its not working: 1 \documentclass{article} 2 \usepackage{xepersian} 3 \settextfont{XB Niloofar} 4 \title{ {یک سند نمونه 5 \author{ {نام نویسنده 6 \begin{document} 7 \maketitle 8 \tableofcontents 9 \part{ {عنوان بخش 10 ... 11 \section{ {عنوان قسمت 12 ... 13 \subsection{ {عنوان زیرقسمت 14 ... 15 \subsubsection{ {عنوان زیر زیرقسمت 16 ... 17 \end{document} – Sina Jun 18 '13 at 18:32
  • @HasanZakeri: I was wondering whether if the problem is the distribution of TEX. I'm using currently MiKTeX 2.9, should I try TeX Live? – Sina Jun 18 '13 at 18:47
  • Update all of your packages (including XePersian and bidi) and tex distribution. – smh Jun 18 '13 at 20:15
  • @smh: I tried upgrading the packages and bidi. It's not working, and it gets worse when I upgrade the packages by receiving lots of error! I'm trying to upgrade TEX distribution. – Sina Jun 18 '13 at 21:01

I changed my TeX distribution to TeX Live and the problem was solved!

thanks to Hasan Zakeri and smh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.