7

I am trying to format my tables and figures' captions with the caption package. What I want is the caption label separated from the caption text by a new line and both of them completly to the left margin. Here is my attempt (and MWE):

\documentclass[a4paper,10pt]{article}
\usepackage[english]{babel}
\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{xltxtra}
\usepackage{threeparttable,booktabs}
\usepackage{lipsum}

\usepackage{ragged2e}
\usepackage{caption}
\captionsetup{%
   labelsep=newline,
   justification=raggedright,
   labelfont=bf
}

\begin{document}
\lipsum[1]
\begin{table}[htpb]\centering
\caption{Title.}
\begin{tabular}{@{}ccc@{}}\toprule
  abc & abc & abc \\
  abc & abc & abc \\
\bottomrule
\end{tabular}
\end{table}
\lipsum[1]
\end{document}

And this is the output:

Caption with options enabled

This only way to do what I want is to created a long title:

Long title with option disabled

Then the raggedleft option works:

Long title with raggedleft

Am I missing something ? Why don't raggedright and raggedleft options work for a sort caption ?

  • 4
    Add the option singlelinecheck=off to deactivate centered short captions. – Gonzalo Medina Jun 21 '13 at 15:48
  • If you have an up-to-date TeX distribution, loading xunicode and xltxtra is not recommended any more. – egreg Jun 21 '13 at 17:42
10

By default, short captions (spanning no more than one line) will be centered (this is so in standard LaTeX, and the caption package honors this convention); deactivate this using singlelinecheck=off:

\usepackage{caption}
\captionsetup{%
   labelsep=newline,
   justification=raggedright,
   labelfont=bf,
  singlelinecheck=off
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.