3

I'm translating a CV into German, under both OS X and Windows 7 with MiKTeX. The problem is that German doesn't work. I tried French, Italian, Dutch and they all work. Any idea where I should look for a resolution?

\documentclass[10pt,ngerman,nologo]{europecv}

I get no errors, nothing, just the result is in English. For the record, AppData\Roaming\MiKTeX\2.9\tex\latex\europecv contains all the expected language templates (ecvde.def being the interesting one). I simply copied the German words into ecven.def but that's ridiculous.

LE. I'm actually generating the document with LyX. If I export it the language appears as in the code snippet above - ngerman. It would seem that german is the correct setting; I'm still investigating.

1
  • Welcome to TeX.SX! Your post was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. Jun 22 '13 at 22:59
4

OK, so it would seem that the proper way to use the german template is german and not ngerman. In LyX, that setting is triggerable by Document - Settings - Language - German (old spelling).

It would be cool to know how to treat the "new" variant of spelling, but yeah.

2

The package documentation: http://mirrors.ctan.org/macros/latex/contrib/europecv/europecv.pdf

Page 2:

Language options

Important!

The following options are not related to babel. See the Notes at the end of this list

Page 3:

Notes

The choice of the language only affects the appearance of the title (“Europass Curriculum Vitæ”), the personal information section, the spoken language table and the footer with the page number. In some cases, it may affects the used alphabet (e.g. in Bulgarian). If you want to use the hyphenation patterns for the language(s) of your choice, you must include the babel package in your document.

Try to add ngerman:

http://www.namsu.de/Extra/pakete/German.html

Eingebunden werden sie mit folgendem Befehl

\usepackage{german} bzw. \usepackage{ngerman}

Alternativ über das babel Paket

\usepackage[german]{babel} bzw. \usepackage[ngerman]{babel}

Hierbei wird german bzw. ngerman als Option des Paketes babel gesetzt.

I personally prefer the method

\usepackage{german}
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.