1

How can I make the table and figure captions aligned in the list of tables or list of figures , my problem is that the list of figures and list of tables are going outside the page margins.

\documentclass[b5paper, 12pt]{report}
\begin{document}
\tableofcontents
\listoffigures
\listoftables
% the table caption is long when it added to the list of tables.
\begin{table}%[position specifier]
 \centering
   \caption{Comparison with "Indirect Ident." method with a white noise disturbance}
\begin{tabular}{| l | l | l | l |l |}\hline
 method& criterion& 25dB & 15dB & 10dB \\ \hline
      \end{tabular}
\end{table}
\end{document}
  • 1
    Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Mensch Jun 22 '13 at 20:15
  • 3
    Does the document posted actually show the problem you're having? When I compile it, it wraps the caption in the list of tables correctly. Maybe you have a long technical word in the caption that TeX doesn't know how to hyphenate properly? – Alan Munn Jun 22 '13 at 22:28
  • Actually with me, it does not wrap the caption in the list of tables correctly. But I found another solution by using a small caption to appear in the list of tables: \caption [small caption] { long caption}. This is not the suitable solution for me. – user16558 Jun 22 '13 at 22:52
1

If you are using package hyperref with a driver that does not support links that breaks across lines (e.g. dvips), then option linktocpage helps. It makes the page number to a link and removes the unbreakable link from the title.

Example file with David Carlisle's quoting fix:

\documentclass[b5paper, 12pt]{report}
\usepackage[
  colorlinks,
  linktocpage,
]{hyperref}

\begin{document}
\tableofcontents
\listoffigures
\listoftables
\begin{table}%[position specifier]
 \centering
   \caption{Comparison with ``Indirect Ident.'' method with a white noise
 disturbance}
\begin{tabular}{| l | l | l | l |l |}\hline
 method& criterion& 25dB & 15dB & 10dB \\ \hline
      \end{tabular}
\end{table}
\end{document}

Result

  • This works correctly with me. Thank you very much. – user16558 Jun 24 '13 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.