5

Obtaining the example code

I tried compiling the classicthesis example documents, especially classicthesis-book.tex. Therefore I copied the directory to my home folder with

cp -R $(kpsewhich -var-value TEXMFDIST)/doc/latex/classicthesis ~/

Then I went to ~/classicthesis/Examples/ and adjusted classicthesis-book.tex, such that

%\usepackage[linedheaders,parts,pdfspacing]{../classicthesis} % ,manychapters
\usepackage[linedheaders,parts,pdfspacing]{classicthesis} % ,manychapters

because classicthesis.sty is not in the directory above. Then I compiled using

pdflatex classicthesis-book.tex

It completed without errors. I reran this some times to get the index updated.

Problem

When executing the above work flow, there are no small caps in the TOC for the part numbers. Compare these two

Original

enter image description here

Self compiled

enter image description here

1 Answer 1

4

The problem is in a strange behavior of titlesec that makes impossible to use tocloft commands for adjusting the appearance of the part entries in the TOC.

The following code in the preamble seems to fix the issue:

\makeatletter
\def\ttl@tocpart{%
  \def\ttl@a{\protect\numberline{\thepart}\@gobble{}}}
\makeatother
\setlength{\cftpartnumwidth}{1.5em}

enter image description here

3
  • 1
    Thank you, it worked. Could you please be so kind, as to add a short explanation of what your code does? Jun 23, 2013 at 19:56
  • 2
    @HenriMenke To be honest, I don't really know what precisely the various incarnations of \ttl@a do in titlesec. I found this workaround (in a different context) and tried it with your problem. Probably @JavierBezos can explain it.
    – egreg
    Jun 23, 2013 at 20:00
  • Do we really need \setlength{\cftpartnumwidth}{1.5em} here? I don't see a difference when I remove it. Jun 23, 2013 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .