I'm typesetting the proceedings of a conference with texts either in German or in English with bibliographies at the end of each text. In English texts I'd like to have the bibliography in English and in German texts in German. I tried to do it this way:

  author = {Felix Jacoby},
  title = {Über die Entwicklung der Griechischen Historiographie und den Plan
einer neuen Sammlung der griechischen Historikerframgmente},
  booktitle = {Abhandlungen zur Griechischen Geschichtsschreibung},
  year = {1956},
  editor = {Bloch, Herbert and Maier, Karl},
  pages = {16-64},
  address = {Leiden}
\section{Erster Beitrag}
Im Text: \cite{bloch_uber_1956}.

\section{Second article}
In text citation:  \cite{bloch_uber_1956}.

The language is switched to English in the second section, but not the bibliography strings in the bibliography: They are still set to the mainlanguage German, so it's still “Hrsg. von“ instead of ”ed. by“ and ”S.“ instead of ”pp.“ for example.

Have I missed something in the biblatex manual or can this not be achieved with biblatex?

(The same problem occurs with babel and pdflatex.)

closed as off-topic by Joseph Wright Jun 28 '13 at 7:18

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I can't reproduce the problem with babel after replacing all non-compliant babel code (lines 2-5) with \usepackage[english,german]{babel}. biblatex does not fully support polyglossia. This is a known issue. – Audrey Jun 25 '13 at 16:38
  • I have the problem also with Babel (as I wrote). I am with babel.sty 2013/05/16 v3.9f and biblatex2.sty 2013/06/17 v2.7. – Stocki Jun 25 '13 at 17:26
  • 1
    Sorry - I didn't assume you were using the development version of biblatex. Install the updated version of 2.7. The initial fix to address a bug introduced by polyglossia 1.3 broke biblatex's patches for babel. Patches to polyglossia language environments never worked anyway so they've been disabled for now. – Audrey Jun 25 '13 at 17:32
  • Installed the updated version of biblatex 2.7 - now it works. – Stocki Jun 25 '13 at 17:51
  • @Stocki On that basis, I will close ('off topic' as that's how we handle cases the issue is a known fixed issue in a package). – Joseph Wright Jun 28 '13 at 7:17