0

A few weeks ago I stumbled into this problem when trying to use texdoc for the very first time. That issue has been resolved.

I completely reinstalled TeXLive 2012, using the complete scheme to ensure that I am installing documentation as well. texdoc -l <packagename> works fine now, it just fails to find relevant documentation pretty often (e.g. for packages tikz, animate, which seem pretty important), showing nothing, or listing documentation to packages which are similar but not the "core" or "main" package... for example, I get the following output:

~> texdoc -l tikz
 1 /usr/local/texlive/2012/texmf-dist/doc/latex/hf-tikz/hf-tikz.pdf
   = Package documentation
 2 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-3dplot/tikz-3dplot_documentation.pdf
   = Package documentation
 3 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-cd/tikz-cd-doc.pdf
   = Package documentation
 4 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-dependency/tikz-dependency-doc.pdf
   = Package documentation
 5 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-inet/tikz-inet-doc.pdf
   = Package documentation
 6 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-qtree/tikz-qtree-manual.pdf
   = Package documentation
 7 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-timing/tikz-timing.pdf
   = Package documentation
 8 /usr/local/texlive/2012/texmf-dist/doc/latex/sa-tikz/sa-tikz-doc.pdf
 9 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-qtree/README
   = Readme
10 /usr/local/texlive/2012/texmf-dist/doc/latex/sa-tikz/README
   = Readme
11 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-3dplot/README
   = Readme
12 /usr/local/texlive/2012/texmf-dist/doc/latex/hf-tikz/README
   = Readme
13 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-inet/README
   = Readme
14 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-timing/README
   = Readme
15 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-cd/README
   = Readme
16 /usr/local/texlive/2012/texmf-dist/doc/latex/hf-tikz/README.txt
17 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-dependency/README
18 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-dependency/AUTHORS
19 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-3dplot/CHANGELOG
20 /usr/local/texlive/2012/texmf-dist/doc/latex/tikz-dependency/VERSION
Please enter the number of the file to view, anything else to skip:

Lots of interesting stuff, but the main PGF/TikZ manual seems not to be there. Another example would be the package beamer for creating slides:

~> texdoc -l beamer
 1 /usr/local/texlive/2012/texmf-dist/doc/latex/beamer-tut-pt/tutorialbeamer.pdf
   = [pt] 
Please enter the number of the file to view, anything else to skip: 

A nice tutorial, but I don't speak portuguese, which is the language this document is in... :)

Another example would be the command texdoc -l animate, which output consists of only a Polish (!) .html file.

Since my whole purpose for using texdoc was to avoid manually searching the web for documentation of (La)TeX packages (which might not correspond to the version of the packages I have installed...), I would like to know:

Is this lack of appropiate documentation for important packages a technical, or rather a political issue? (e.g. the package developers don't include the documentation on CTAN because of licensing issues, or beacuse they want to attract traffic to their websites) or did I screw up (again) and didn't install the documentation properly? Could anyone using TL2012 run a check on their own system and compare the output of texdoc?

  • The first result of texdoc -l tikz is the pgfmanual, and for beamer, the english beameruserguide. I'm using TL2013, but I didn't notice any change in the results of texdoc when upgrading. Can you try texdoc -l pgfmanual? – T. Verron Jun 26 '13 at 15:40
  • @T.Verron texdoc -l pgfmanual returns "no documentation found". – MaxAxeHax Jun 26 '13 at 15:41
  • 3
    I guess there's something wrong with your installation again, then. :/ – T. Verron Jun 26 '13 at 15:43
  • @T.Verron: i get the same results with a [terminally :-] up-to-date tl'12; so version numbers aren't the problem. – wasteofspace Jun 26 '13 at 16:16
  • @MHaaZ: when did you change to the fuller installation scheme? -- were there any error messages? i ask, because tl'12, which you and i both have, can no longer be updated ... if you tried to change scheme after updates were switched off, it wouldn't have worked (i would have expected an error message, but there we are...) if this is what happened, you'll need to update to tl'13 ... a time-wasting performance. (there haven't been any big changes between the close of tl'12 and the advent of tl'13 ... i get to see them all.) – wasteofspace Jun 26 '13 at 16:26
3

This is not a general problem: texdoc -l tikz with TeX Live 2012 or TeX Live 2013 gives

 1 /usr/local/texlive/2013/texmf-dist/doc/generic/pgf/pgfmanual.pdf
   = PGF Manual

as the first hit. As such, this looks like an localised issue with your installation. All that can really be recommended is to remove the installation and redo.

0

On my system with Tex Live 2012 texdoc -l tikz gives:

21 results.  Display them all? (y/N) y
 1 /usr/local/texlive/2012/texmf-dist/doc/generic/pgf/pgfmanual.pdf
   = PGF Manual
...
Please enter the number of the file to view, anything else to skip: 

If you use a Mac, try TexShop and select Help/Show Help for Package then type the package name in the texdoc dialog box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.