2

For the first time I have used the Edit > Check Spelling feature on Texmaker to extensively check a large document. During the process, I have clicked the Always ignore button for some words. Now, those words are as if in the dictionary and are not properly checked for spelling. Here is an example:

Texmaker spell check.

The rel and res words are not correct and should be red underlined. Texmaker must have added those words to some file without my knowledge--I though the always ignore option was for that session only. I did this on a previous version of Texmaker on Mac OS Snow Leopard. I've reinstalled to the most recent version (4.0.2) and the problem persists.

I guess that the underlying TeX engine has nothing to do with this.

Anything to do with Hunspell?

How can I fix it?

  • Hi and a big welcome to TeX.SX! I'm not using Texmaker but in TexStudio (on Windows) when a word is "always ignored", it's automatically added to a particular file, named en_GB.ign (or whatever, according to your language). Check if this file is empty -- it should be in the \dictionaries folder in the Texmaker istallation root. – bersanri Jun 27 '13 at 12:09
  • Thanks. Texmaker does not have that folder on Mac OS nor find / -name "en_US.ign" (I was using the American dictionary) finds the file through the terminal. – dfernan Jun 27 '13 at 12:33
3

The "always ignored words" are stored in the Texmaker configuration file. "Options" -> "Settings file" -> "reset settings".

And, if you want to ignore a word for only one document, just use the "ignore" button and not the "always ignore" one.

  • Worked! Thanks for the heads up. Did not know about that configuration file. It sure eases copying Texmaker settings from one computer to another. – dfernan Jun 27 '13 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.