1

When I use the package xfrac all of my °-signs are gone.

\documentclass[12pt,a4paper,headinclude,headsepline,twoside,parskip=half,DIV12,BCOR12mm,numbers=noenddot]{scrreprt}
\usepackage{rotating} 
\usepackage{ngerman}
\usepackage[latin1]{inputenc}
\pagestyle{headings}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{siunitx} 
%\sisetup{per-mode=fraction, fraction-function=\sfrac}
\usepackage{xfrac} 

\begin{document}

\ang{10}

10°

\si{\degree}

\end {document}

Without xfrac everything is working fine. It doesn't occur if I use pdflatex.

I'm using Windows 7-64bit with TexnicCenter and Miktex 2.9.

Thanks in advance for helping me!

Bye, Michael

  • 4
    I see the symbol in all three cases. – egreg Jun 27 '13 at 23:41
  • 1
    Do you have the cm-super package installed? Btw: Don't use the ngerman package, use \usepackage[ngerman]{babel}. – Ulrike Fischer Jun 28 '13 at 8:52
1

Just to end this: I'm using a current MiKTeX 2.9 system on Windows 7 and have no problems with your given MWE (same as @egreg said in his comment).

So I guess you are using an outdated TeXLive version? If so please update first!

As @Ulrike remarks in her comment you used an outdated package ngerman. Better use package babel instead.

Document class scrreprt from KOMA-Script handels some options now as key=value.

I have changed your MWE, pretty printed it and used the KOMA-Script syntax:

\documentclass[%
  ngerman          % given to all packages using languages
 ,fontsize=12pt    % default is 11pt
 ,paper=a4         % default
 ,headinclude      %
 ,headsepline      %
 ,twoside          % default is oneside
 ,parskip=half     % 
 ,DIV=12           % calculates typing area
 ,BCOR=12mm        % 12mm für die Bindung!
 ,numbers=noenddot %
]{scrreprt}

\usepackage[latin1]{inputenc}
\usepackage{babel}            % gets ngerman from class option

%\usepackage{amsmath}
%\usepackage{amssymb}
\usepackage{siunitx}

%\sisetup{per-mode=fraction, fraction-function=\sfrac}
\usepackage{xfrac} 

\begin{document}

\ang{10}

10°

\si{\degree}

\end {document}
0

I also can't reproduce the error. As a work-around, perhaps you could try $^\circ$ as a degree sign?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.