I just got a macbook air (the version right before the current one) and I have MacTex installed and I have the latex plugin for gedit. How can I get gedit to compile pdf for me? Before on ubuntu I just hit ctrl + alt + 1 and it worked but nothing is happening now.

Though, I can use texshop but I prefer gedit due to the black background.

  • Do you have rubber installed? The latex gedit plugin relies on it to compile documents AFAIK.
    – Xavier
    Jun 29, 2013 at 4:48
  • 1
    TeXshop for those interested Jun 29, 2013 at 5:46
  • You can install rubber with Homebrew. But I suggest switching to a different editor/front end such as Aquamacs or TeXShop.
    – egreg
    Jun 29, 2013 at 8:49
  • Dear @egreg, I'm fine with using texshop, the only thing is the white background and my high powered glasses make it unpleasant to type things over a long period of time. How can I change the backgound color in texshop to black; or dark blue as I had on my old gedit? Jun 29, 2013 at 9:26

1 Answer 1


The background color of TeXShop can easily be changed in the preferences. Just select TexShop->Preferences... from the menu and look for Background Color in the Source tab:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .