yesterday I tried to remove the all-caps of my ToC, LoF, ... in my documents header and think I encountered a problem/bug. My MWE:

\documentclass[12pt, oneside, a4paper]{book}
\usepackage[paper = a4paper, margin = 1in, headheight = 14.5pt, includehead]{geometry}
 \fancyhead[L]{\itshape \leftmark}


As you can see I'm using tocbibind to include my LoF and LoT in the ToC. My problem is, if I use \renewcommand{\tocetcmark}[1]{\markboth{#1}{}} it only displays my LoF and LoT normalsized in my header. But the documentation for tocbibind says that this command is for ToC, LoF, ... . Why is my ToC still all-caps? Is it some kind of bug or am I overlooking something?

In one of my previous questions (Customize \chaptermark for \mainmatter) Heiko Oberdiek already gave me a solution for the ToC problem in advance:


It works really fine, but why doesn't the first method does it job properly? Or is there even a smarter way to remove all the all-caps at once?

1 Answer 1


The package tocbibind only overwrites default definitions of listof<...> which you have specified. You passed the option nototoc and so there is no redefinition of the default \tableofcontents. So you have to use the provided patch of Heiko.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .